6 Replies Latest reply: May 17, 2019 5:56 PM by Ing_Percy RSS

    Creating voip connection

    Yosif

      Hey i've been playing here with the IP Phones . I've set up a 2811 router and made the pool go through vlan 7 . The IP Phones still don't get the configuration.

      Router 2811

      ___________________________

      Building configuration...

       

      Current configuration : 1149 bytes

      !

      version 12.4

      no service timestamps log datetime msec

      no service timestamps debug datetime msec

      no service password-encryption

      !

      hostname VOIP-Router

      !

      ip dhcp pool VOIP-Vlan

      network 192.168.3.0 255.255.255.0

      default-router 192.168.3.254

      option 150 ip 192.168.3.254

      !

      ip cef

      no ipv6 cef

      !

      spanning-tree mode pvst

      !

      interface FastEthernet0/0

      no ip address

      duplex auto

      speed auto

      !

      interface FastEthernet0/0.7

      encapsulation dot1Q 7

      ip address 192.168.3.254 255.255.255.0

      !

      interface FastEthernet0/1

      no ip address

      duplex auto

      speed auto

      shutdown

      !

      interface Vlan1

      no ip address

      !

      ip classless

      !

      ip flow-export version 9

      !

      telephony-service

      max-ephones 15

      max-dn 15

      ip source-address 192.168.3.254 port 2000

      auto assign 4 to 6

      auto assign 1 to 5

      !

      ephone-dn 1

      number 0001

      !

      ephone-dn 2

      number 0002

      !

      ephone-dn 3

      number 0003

      !

      ephone-dn 4

      number 0004

      !

      ephone-dn 5

      number 0005

      !

      ephone-dn 6

      number 0006

      !

      ephone-dn 7

      number 0007

      !

      ephone-dn 8

      number 0008

      !

      ephone-dn 9

      number 0009

      !

      ephone-dn 10

      number 0010

      !

      line con 0

      !

      line aux 0

      !

      line vty 0 4

      login

      !

      end

      _________________________________

      Switch which connects to the switch with the phones .

      __________________________________

      Building configuration...

       

      Current configuration : 1827 bytes

      !

      version 12.2

      no service timestamps log datetime msec

      no service timestamps debug datetime msec

      service password-encryption

      !

      hostname ControlSwitch2

      !

      enable secret 5 $1$mERr$XmQvQXqotoKiiXOag2f57.

      enable password 7 08375C40584B56

      !

      spanning-tree mode pvst

      spanning-tree extend system-id

      !

      interface FastEthernet0/1

      switchport trunk allowed vlan 1-7

      switchport mode trunk

      switchport voice vlan 7

      !

      interface FastEthernet0/2

      switchport trunk allowed vlan 1-7

      switchport mode trunk

      switchport voice vlan 7

      !

      interface FastEthernet0/3

      switchport trunk allowed vlan 1-7

      switchport mode trunk

      switchport voice vlan 7

      !

      interface FastEthernet0/4

      switchport trunk allowed vlan 1-7

      switchport mode trunk

      switchport voice vlan 7

      !

      interface FastEthernet0/5

      switchport trunk allowed vlan 1-7

      switchport mode trunk

      switchport voice vlan 7

      !

      interface FastEthernet0/6

      switchport trunk allowed vlan 1-7

      switchport mode trunk

      switchport voice vlan 7

      !

      interface FastEthernet0/7

      switchport voice vlan 7

      !

      interface Vlan1

      no ip address

      shutdown

      !

      interface Vlan4

      mac-address 0040.0b40.3001

      ip address 10.0.0.98 255.0.0.0

      !

      line con 0

      password 7 08375C40584B56

      login

      !

      line vty 0 4

      password 7 08375C40584B56

      login

      line vty 5 15

      login

      !

      end

      ______________________________

      The conf of the switch with the phones

      ______________________________

      Building configuration...

       

      Current configuration : 2294 bytes

      !

      version 12.2

      no service timestamps log datetime msec

      no service timestamps debug datetime msec

      service password-encryption

      !

      hostname CustomerSwitch

      !

      enable secret 5 $1$mERr$XmQvQXqotoKiiXOag2f57.

      !

      !

      !

      no ip domain-lookup

      !

      !

      spanning-tree mode pvst

      spanning-tree extend system-id

      !

      interface FastEthernet0/1

      switchport access vlan 2

      switchport mode access

      !

      interface FastEthernet0/2

      switchport access vlan 2

      switchport mode access

      !

      interface FastEthernet0/3

      switchport access vlan 2

      switchport mode access

      !

      interface FastEthernet0/4

      switchport access vlan 2

      switchport mode access

      !

      interface FastEthernet0/5

      switchport access vlan 2

      switchport mode access

      !

      interface FastEthernet0/6

      switchport access vlan 2

      switchport mode access

      !

      interface FastEthernet0/7

      switchport access vlan 7

      switchport mode access

      switchport voice vlan 7

      !

      interface FastEthernet0/8

      switchport access vlan 7

      switchport mode access

      switchport voice vlan 7

      !

      interface FastEthernet0/9

      switchport access vlan 7

      switchport mode access

      switchport voice vlan 7

      !

      interface FastEthernet0/10

      switchport access vlan 7

      switchport mode access

      switchport voice vlan 7

      !

      interface FastEthernet0/11

      switchport access vlan 7

      switchport mode access

      switchport voice vlan 7

      !

      interface FastEthernet0/12

      switchport access vlan 2

      switchport trunk allowed vlan 1-7

      switchport mode trunk

      switchport voice vlan 7

      !

      interface FastEthernet0/13

      switchport access vlan 2

      switchport trunk allowed vlan 1-7

      switchport mode trunk

      switchport voice vlan 7

      !

      interface Vlan1

      no ip address

      !

      interface Vlan4

      mac-address 0090.0c44.ab01

      ip address 10.0.0.95 255.0.0.0

      !

      !

      !

      !

      line con 0

      password 7 08375C40584B56

      login

      !

      line vty 0 4

      password 7 08375C40584B56

      login

      line vty 5 15

      login

      !

      !

      !

      !

      end