4 Replies Latest reply: May 16, 2019 12:17 PM by Raulisess RSS

    EIGRP Route filtering - logic

    Raulisess

      Hi

       

      I'm playing around filtering route advertisements on GNS3.

      In the lab I'm doing a router has 5 loopbacks, first is asking me to filter one of them out without using a distribute list. I have chosen to do it in the following way and works although it might not be the intended of best way:

      - I have redistributed into EIGRP connected routes and used a route map to filter that one network out. It worked fine to achieve the asked objetive.

         None of those loopback networks have been announced to EIGRP by matching a network statement, just by being redistributed.

       

      Then I'm asked to filter another loopback network out but this time using an outbound distribute-list. On my first attempt I chose to filter using "DISTRIBUTE_LIST x out EIGRP" this didn't work. Then I used "...out Interfaces..." this worked and filtered the nerwork out.

      My question is:

      Why "...out EIGRP" didn't work?

       

      To be more specific:(running config of R1 below)

      Task 1- on R1 filtered out network 111.111.111.64/27 wihtout using a distribute-list. I used the redistribute connected + route-map approach here

      Task 2- Filter out network 111.111.111.32/28 using a distribute-list. My first approach using "distribute-list 2 out EIGRP" did not work. Then I used "

      distribute-list 2 out FastEthernet0/0" and "distribute-list 2 out Serial2/0" and worked.

       

      Does it something to do with the way EIGRP learnt them?  REDISTRIBUTE rather than NETWORK commnad?

       

       

      interface Loopback0

      ip address 111.111.111.1 255.255.255.248

       

      interface Loopback1

      ip address 111.111.111.9 255.255.255.248

       

      interface Loopback2

      ip address 111.111.111.17 255.255.255.248

       

      interface Loopback3

      ip address 111.111.111.25 255.255.255.252

       

      interface Loopback4

      ip address 111.111.111.33 255.255.255.240

       

      interface Loopback5

      ip address 111.111.111.65 255.255.255.224

       

      interface FastEthernet0/0

      ip address 1.2.1.1 255.255.255.0

      duplex half

      !

      interface Serial2/0

      ip address 1.4.1.1 255.255.255.0

      !

      router eigrp INE

      !

      address-family ipv4 unicast autonomous-system 100

        !

        topology base

         distribute-list 2 out FastEthernet0/0

         distribute-list 2 out Serial2/0

         redistribute connected metric 1500 10 255 1 1500 route-map MAP

        exit-af-topology

        network 1.2.1.0 0.0.0.255

        network 1.4.1.0 0.0.0.255

      exit-address-family

       

      access-list 1 permit 111.111.111.64 0.0.0.63

      access-list 2 deny   111.111.111.32 0.0.0.31

      access-list 2 permit any

      !

      route-map MAP deny 10

      match ip address 1

      !

        • 1. Re: EIGRP Route filtering - logic
          Mohamed

          access-list 1 permit 111.111.111.64 0.0.0.63

          access-list 2 deny   111.111.111.32 0.0.0.31

          why you have different access lists ?

          use only one access list ((for ex use access-list 1)

          remove the second line

          • 2. Re: EIGRP Route filtering - logic
            Raulisess

            no takers?

            • 3. Re: EIGRP Route filtering - logic
              Ing_Percy

              Hi!

               

              Raulisess escribió:

               

              To be more specific:(running config of R1 below)

              Task 1- on R1 filtered out network 111.111.111.64/27 wihtout using a distribute-list. I used the redistribute connected + route-map approach here

              Task 2- Filter out network 111.111.111.32/28 using a distribute-list. My first approach using "distribute-list 2 out EIGRP" did not work. Then I used "

              distribute-list 2 out FastEthernet0/0" and "distribute-list 2 out Serial2/0" and worked.

               

              Does it something to do with the way EIGRP learnt them?  REDISTRIBUTE rather than NETWORK commnad?

               

              router eigrp INE

              !

              address-family ipv4 unicast autonomous-system 100

                !

                topology base

                distribute-list 2 out FastEthernet0/0

                distribute-list 2 out Serial2/0

                redistribute connected metric 1500 10 255 1 1500 route-map MAP

                exit-af-topology

                network 1.2.1.0 0.0.0.255

                network 1.4.1.0 0.0.0.255

              exit-address-family

               

              access-list 1 permit 111.111.111.64 0.0.0.63

              access-list 2 deny  111.111.111.32 0.0.0.31

              access-list 2 permit any

              !

              route-map MAP deny 10

              match ip address 1

              !

              "distribute-list 2 out EIGRP"

              The "distribute-list acl-number out protocol" is for filtering redistribution. For that reason, you are applied to the same protocol (EIGRP), you try with the command: "distribute-list acl-number out connected"


              Here is a case of CLN that comment about it:

              Distribute-list with Routing Process Parameter


              Best regards!

              • 4. Re: EIGRP Route filtering - logic
                Raulisess

                brilliant thanks