6 Replies Latest reply: May 17, 2019 8:03 AM by DavidJ RSS

    Voice/Data Switch Port Configuration

    DavidJ

      Looking for help in configuring a Voice/Data port.  I've used two different configurations based on what I knew and researched, but I can't get the workstation that is inline with the VOIP phone to work.

      Below are the two configs I've used.  The first one was one I used in the past and the second one is one I've researched.  In both cases on the phone is accessible, but the workstation is not.

      We did discover that there is a configuration for the phone to allow the second port to work.

      EQUIPMENT:

      3850-24P-S Cisco Switch

      CP-8861 VOSIP

       

      What is the configuration that I should use and what is missing from the two options below?

       

      interface gig 1/0/4

      des WS5,VOIP42

      switchport access vlan 5

      switchport mode access

      switchport voice vlan 42

      cdp enable

      end

       

       

      interface gig 1/0/4

      des WS5,VOIP42

      switchport trunk native vlan 42

      switchport trunk allowed vlan 5,42

      switchport mode trunk

      switchport voice vlan dot1p

      switchport voice vlan 42

      switchport priority extend trust

      cdp enable

      authentication periodic

      trust device cisco-phone

      spanning-tree portfast

      end

         
        • 1. Re: Voice/Data Switch Port Configuration
          Ing_Percy

          Hi!

           

          In both cases, Can the workstation make ping to its gateway? Is configured in the switch the gateways for vlan 5 and vlan 42 (interface vlan 5 and 42)? also, is enabled the routing in the switch?

           

          Please, add more configurations

           

          Regards!

          • 2. Re: Voice/Data Switch Port Configuration
            DavidJ

            Ing, thanks for responding.

            1.  In both cases, Can the workstation make ping to its gateway?  No

            2.  The switch has both/all vlans trunked up to the L3 Distro devices

            3.  Routing is enabled on the L3 Distro only


              Both devices work on the same port as a single configuration.  When configured for Inline the phone works and the computer doesn't.

             

            Which configuration is correct or more correct?

            • 3. Re: Voice/Data Switch Port Configuration
              DavidJ

              One additional update.  We already had VOIP VLAN 41 operational for two years.

                The difference is newer phones.  The original phones are CP-7975 connected to a CM using 10.6 and the new phones are connected to a CM using 11.2

                I'm guessing that this is not a routing issues as both Voice VLANs are configured the same.  We've just never connected the phones inline.

              • 4. Re: Voice/Data Switch Port Configuration
                Ing_Percy

                Hi!

                 

                The issue is in the workstation as you mentioned.

                 

                The conventional configuration in the switch is the following:

                 

                interface GigabitEthernet0/10

                description PHONE-PC

                switchport access vlan 100

                switchport mode access

                switchport voice vlan 200

                switchport port-security maximum 2

                switchport port-security violation restrict

                switchport port-security

                mls qos trust device cisco-phone

                mls qos trust cos

                spanning-tree portfast

                spanning-tree bpduguard enable

                 

                The configuration of the workstation. Can this host make ping to another hosts?

                 

                Regards!

                • 5. Re: Voice/Data Switch Port Configuration
                  Mustafa

                  a real port configuration from production switch

                   

                  =======================

                  interface FastEthernet0/2

                  description xxxxxxx

                  switchport access vlan 83

                  switchport mode access

                  switchport voice vlan 100

                  spanning-tree portfast

                  spanning-tree bpduguard enable

                  =========================

                  vlan 83 is Data vlan for users

                  vlan 100 is voice vlan

                   

                  if you have only one switch this is enough

                  if you have upstream switch you also need these vlans configured on it and allowed on trunk between switches

                   

                  ===

                  Be careful about second config of port

                  read the article about voice vlan

                  Confusion about voice vlan | Tom G CCIE Blog

                  • 6. Re: Voice/Data Switch Port Configuration
                    DavidJ

                    FM!

                    Left it last night in the below config and this morning both the computer and phone were working.  This is the first config I used and have used before.  I only attempted the trunk commands because of a Cisco configuration I found.

                     

                    interface gig 1/0/4

                    des WS5,VOIP42

                    switchport access vlan 5

                    switchport mode access

                    switchport voice vlan 42

                    cdp enable

                    end