0 Replies Latest reply: May 13, 2019 1:23 AM by Damien RSS

    please help . cisco 1941 with 4 esw hwic +[ pppoe + nat overload + shaping]

    Damien

      Hi everyone. I'm hoping someone can help me with a config?

      I'm trying to configure a 1941 for a pppoe service delivered by fibre and presented as a fast ethernet interface . Service is 100 mbps down and 5 mbps up. Customer has an ISP supplied gateway device (technicolor tg799) and runs a small business from home (uses: video conferencing, cloud based accounting software and https traffic outbound as well as "usual" traffic). I've done a protocol trace between ntd and gateway and can see upstream hitting 10 mbps frequently. They are complaining about slow speeds. I'd like to show them how a shaped router would behave better than a $100 gateway device. I know this is overkill but I have spare 1941's sitting around the lab and it's just to prove the network. (I work for the ISP).

      (LAB) Problem is I can't ping any external addresses from the dhcp clients. I can ping from the router itself in IOS . show ip nat statistics shows nothing. sh ip dhcp binding shows that I'm getting an address.  Here is my config

       

      !

      ip dhcp excluded-address 192.168.0.1

      ip dhcp excluded-address 192.168.0.254

      !

      ip dhcp pool pool

      network 192.168.0.0 255.255.255.0

      default-router 192.168.0.1

      dns-server 61.9.211.1 8.8.8.8

      !

      policy-map policy1

      class class-default

        fair-queue

        shape average 4750000

      !

      !

      interface GigabitEthernet0/0

      description wan

      bandwidth 5000

      no ip address

      pppoe enable

      pppoe-client dial-pool-number 1

      ip nat outside

      service-policy output policy1

      duplex auto

      speed auto

      !

      interface GigabitEthernet0/1

      no ip address

      duplex auto

      speed auto

      shutdown

      !

      interface FastEthernet0/0/0

      switchport mode access

      switchport nonegotiate

      !

      interface FastEthernet0/0/1

      switchport mode access

      switchport nonegotiate

      !

      interface FastEthernet0/0/2

      switchport mode access

      switchport nonegotiate

      !

      interface FastEthernet0/0/3

      switchport mode access

      switchport nonegotiate

      !

      interface Dialer2

      dialer pool 1

      ip address negotiated

      mtu 1492

      encapsulation ppp

      ppp chap hostname user

      ppp chap password password

      !

      interface Vlan1

      ip address 192.168.0.1 255.255.255.0

      ip nat inside

      !

      ip nat inside source list NAT_POOL interface GigabitEthernet0/0 overload

      ip classless

      ip route 0.0.0.0 0.0.0.0 Dialer2

      !

      ip access-list standard NAT_POOL

      permit 192.168.0.0 0.0.0.255

      !