2 Replies Latest reply: Mar 15, 2019 11:19 AM by BadDog773 RSS

    How do I summarize OSPF area 0?

    BadDog773

      Hi,

       

      I am just trying to learn about the CCNP route as I prepare my exam in the future. My question is

      how do I summarize OSPF loopback on R1 to display on summarize route on R2?

       

      R1 - fa0/1 & R2 - fa0/1 are both in area 0.

       

      More specifically, I have loopback networks for 10.20.0.0/24, 10.20.1.0/24, 10.20.2.0/24, 10.20.3.1/24.

      I know summarize IP address range would be 10.20.0.0/22

       

      I had tried multiple combination on R1 with the "area 0 range 10.20.0.0 255.255.252.0" or with "advertise"

      command including with "summary address 10.20.0.0 255.255.252.0". Still not working as intended.

       

      Any clue or suggestion or to do this?

      OSPF Sum.PNG

      R1#show running-config

      *Mar  1 01:54:27.383: %SYS-5-CONFIG_I: Configured from console by console

      R1#show running-config

      Building configuration...

       

      Current configuration : 1949 bytes

      !

      version 12.4

      service timestamps debug datetime msec

      service timestamps log datetime msec

      no service password-encryption

      !

      hostname R1

      !

      boot-start-marker

      boot-end-marker

      !

      !

      no aaa new-model

      memory-size iomem 5

      no ip icmp rate-limit unreachable

      ip cef

      !

      !

      !

      !

      no ip domain lookup

      !

      multilink bundle-name authenticated

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      archive

      log config

        hidekeys

      !

      !

      !

      !

      ip tcp synwait-time 5

      !

      !

      !

      !

      interface Loopback0

      ip address 10.20.0.1 255.255.255.0

      ip ospf network point-to-point

      !

      interface Loopback1

      ip address 10.20.1.1 255.255.255.0

      ip ospf network point-to-point

      !

      interface Loopback2

      ip address 10.20.2.1 255.255.255.0

      ip ospf network point-to-point

      !

      interface Loopback3

      ip address 10.20.3.1 255.255.255.0

      ip ospf network point-to-point

      !

      interface FastEthernet0/0

      ip address 64.0.0.5 255.255.255.252

      duplex auto

      speed auto

      !

      interface Serial0/0

      no ip address

      shutdown

      clock rate 2000000

      !

      interface FastEthernet0/1

      ip address 64.0.0.1 255.255.255.252

      duplex auto

      speed auto

      !

      interface Serial0/1

      no ip address

      shutdown

      clock rate 2000000

      !

      interface Serial0/2

      no ip address

      shutdown

      clock rate 2000000

      !

      interface Serial0/3

      no ip address

      shutdown

      clock rate 2000000

      !

      interface FastEthernet1/0

      no ip address

      shutdown

      duplex auto

      speed auto

      !

      interface FastEthernet2/0

      no ip address

      shutdown

      duplex auto

      speed auto

      !

      router ospf 1

      router-id 1.1.1.1

      log-adjacency-changes

      area 0 range 10.20.0.0 255.255.252.0

      summary-address 10.20.0.0 255.255.252.0

      network 10.20.0.0 0.0.3.255 area 0

      network 64.0.0.0 0.0.0.3 area 0

      network 64.0.0.4 0.0.0.3 area 0

      !

      ip forward-protocol nd

      !

      !

      no ip http server

      no ip http secure-server

      !

      no cdp log mismatch duplex

      !

      !

      !

      !

      !

      !

       

      R1#

      R1#show run

      R1#show running-config

      Building configuration...

       

      Current configuration : 1949 bytes

      !

      version 12.4

      service timestamps debug datetime msec

      service timestamps log datetime msec

      no service password-encryption

      !

      hostname R1

      !

      boot-start-marker

      boot-end-marker

      !

      !

      no aaa new-model

      memory-size iomem 5

      no ip icmp rate-limit unreachable

      ip cef

      !

      !

      !

      !

      no ip domain lookup

      !

      multilink bundle-name authenticated

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      archive

      log config

        hidekeys

      !

      !

      !

      !

      ip tcp synwait-time 5

      !

      !

      !

      !

      interface Loopback0

      ip address 10.20.0.1 255.255.255.0

      ip ospf network point-to-point

      !

      interface Loopback1

      ip address 10.20.1.1 255.255.255.0

      ip ospf network point-to-point

      !

      interface Loopback2

      ip address 10.20.2.1 255.255.255.0

      ip ospf network point-to-point

      !

      interface Loopback3

      ip address 10.20.3.1 255.255.255.0

      ip ospf network point-to-point

      !

      interface FastEthernet0/0

      ip address 64.0.0.5 255.255.255.252

      duplex auto

      speed auto

      !

      interface Serial0/0

      no ip address

      shutdown

      clock rate 2000000

      !

      interface FastEthernet0/1

      ip address 64.0.0.1 255.255.255.252

      duplex auto

      speed auto

      !

      interface Serial0/1

      no ip address

      shutdown

      clock rate 2000000

      !

      interface Serial0/2

      no ip address

      shutdown

      clock rate 2000000

      !

      interface Serial0/3

      no ip address

      shutdown

      clock rate 2000000

      !

      interface FastEthernet1/0

      no ip address

      shutdown

      duplex auto

      speed auto

      !

      interface FastEthernet2/0

      no ip address

      shutdown

      duplex auto

      speed auto

      !

      router ospf 1

      router-id 1.1.1.1

      log-adjacency-changes

      area 0 range 10.20.0.0 255.255.252.0

      summary-address 10.20.0.0 255.255.252.0

      network 10.20.0.0 0.0.3.255 area 0

      network 64.0.0.0 0.0.0.3 area 0

      network 64.0.0.4 0.0.0.3 area 0

      !

      ip forward-protocol nd

      !

      !

      no ip http server

      no ip http secure-server

      !

      no cdp log mismatch duplex

      !

      !

      !

      !

      !

      !

      control-plane

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      line con 0

      exec-timeout 0 0

      privilege level 15

      logging synchronous

      line aux 0

      exec-timeout 0 0

      privilege level 15

      logging synchronous

      line vty 0 4

      login

      !

      !

      end

       

      ------------------------------

       

      R2#show running-config

      Building configuration...

       

      Current configuration : 1487 bytes

      !

      version 12.4

      service timestamps debug datetime msec

      service timestamps log datetime msec

      no service password-encryption

      !

      hostname R2

      !

      boot-start-marker

      boot-end-marker

      !

      !

      no aaa new-model

      memory-size iomem 5

      no ip icmp rate-limit unreachable

      ip cef

      !

      !

      !

      !

      no ip domain lookup

      !

      multilink bundle-name authenticated

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      archive

      log config

        hidekeys

      !

      !

      !

      !

      ip tcp synwait-time 5

      !

      !

      !

      !

      interface FastEthernet0/0

      ip address 64.0.0.21 255.255.255.252

      duplex auto

      speed auto

      !

      interface Serial0/0

      ip address 64.0.0.18 255.255.255.252

      clock rate 64000

      !

      interface FastEthernet0/1

      ip address 64.0.0.2 255.255.255.252

      duplex auto

      speed auto

      !

      interface Serial0/1

      no ip address

      shutdown

      clock rate 2000000

      !

      interface Serial0/2

      no ip address

      shutdown

      clock rate 2000000

      !

      interface Serial0/3

      no ip address

      shutdown

      clock rate 2000000

      !

      interface FastEthernet1/0

      no ip address

      shutdown

      duplex auto

      speed auto

      !

      interface FastEthernet2/0

      no ip address

      shutdown

      duplex auto

      speed auto

      !

      router ospf 1

      router-id 2.2.2.2

      log-adjacency-changes

      network 64.0.0.0 0.0.0.3 area 0

      network 64.0.0.16 0.0.0.3 area 0

      !

      ip forward-protocol nd

      !

      !

      no ip http server

      no ip http secure-server

      !

      no cdp log mismatch duplex

      !

      !

      !

      !

      !

      !

      control-plane

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      line con 0

      exec-timeout 0 0

      privilege level 15

      logging synchronous

      line aux 0

      exec-timeout 0 0

      privilege level 15

      logging synchronous

      line vty 0 4

      login

      !

      !

      end

       

      R2.PNG