1 2 Previous Next 15 Replies Latest reply: Nov 13, 2018 1:02 PM by Hartline RSS

    VIRL CPU Hog errors

    Federico

      Hi all,

      I installed the last version of VIRL and I tried to run a topology with a single device (just for testing).

      I tried first with a single  IOSvL2 and than with a single IOSv.

       

      I always had the same issue.

      The simulation starts correctly, but all the devices are stuck after the Cisco copyright message

       

      Booted IOSv. Boot args: [/vios_l2-adventerprisek9-m]


      Smart Init is enabled


                    Restricted Rights Legend


      Use, duplication, or disclosure by the Government is

      subject to restrictions as set forth in subparagraph

      (c) of the Commercial Computer Software - Restricted

      Rights clause at FAR sec. 52.227-19 and subparagraph

      (c) (1) (ii) of the Rights in Technical Data and Computer

      Software clause at DFARS sec. 252.227-7013.


                cisco Systems, Inc.

                170 West Tasman Drive

                San Jose, California 95134-1706




      Cisco IOS Software, vios_l2 Software (vios_l2-ADVENTERPRISEK9-M), Experimental Version 15.2(20170321:233949) [mmen 101]

      Copyright (c) 1986-2017 by Cisco Systems, Inc.

      Compiled Wed 22-Mar-17 08:38 by mmen



      -Traceback= 1DDC418z 8DC255z 90582Ez 905550z 90535Dz 9014E5z 90211Bz 9020AFz 1E0162Cz 36E1B28z 36E9B11z 37D2E73z 380C608z - Process "EEM ED Identity", CPU hog, PC 0x008FD955


      -Traceback= 1DDC418z 8DC255z 90582Ez 905550z 90535Dz 9014E5z 90211Bz 9020AFz 1DD025Az 1E01571z 36E1B28z 36E9B11z 37D2E73z 380C608z - Process "EEM ED Identity", CPU hog, PC 0x008FD7F2


      -Traceback= 1DDC418z 8DC255z 90582Ez 905550z 90535Dz 9014E5z 90211Bz 9020AFz 1DD025Az 1E01571z 36E1B28z 36E9B11z 37D2E73z 380C608z - Process "EEM ED Identity", CPU hog, PC 0x008FD7F2



      Does anyone faced the same issue?


      Thank you.

        • 1. Re: VIRL CPU Hog errors
          Karlo Bobiles

          Hello Federico,


          Can you please run the VIRL Server Config Validation script and attach your results to this thread? Also, please refer to the following guide to collect all logs: How to: Collect Logs For VIRL Troubleshooting

           

          Thank you,

          Karlo Bobiles

          Cisco Learning Network

          • 2. Re: VIRL CPU Hog errors
            Federico

            Hi Karlo,

            attached you can find requested logs.

             

            Thank you.

            • 3. Re: VIRL CPU Hog errors
              alejo-VIRL Support

              The CPU HOG errors in IOSv are expected and completely cosmetic. More info in the release notes.

              https://learningnetwork.cisco.com/docs/DOC-34340#jive_content_id_Known_Issues_and_Caveats

               

              As for the nodes not completing the boot sequence...

              based on your system hardware, I would expect a single IOSv node to boot fairly quick; about 2min max. Once the node has booted and after the messages stop, click in the console window and press enter a couple of times. If you are still not able to get a response, with the simulation running please collect the problem report again and attach to your response.

              • 4. Re: VIRL CPU Hog errors
                Federico

                Hello,

                unfortunately all devices still stuck after the copyright disclaimer.

                Attached you can find same reports of before but this time while topology was running (with a single L2 switch)

                 

                Could you please review the logs and let me know if there is something wrong?

                For reference I already tried to delete and create another Virl VM but without any luck.

                 

                Thank you.

                • 5. Re: VIRL CPU Hog errors
                  Federico

                  Hello,

                  did you have any luck with the new logs?

                  Unfortunately, after more than one week, I'm still not able to utilize my VIRL software.

                   

                  Any suggestion?

                   

                  Thank you.

                  • 6. Re: VIRL CPU Hog errors
                    alejo-VIRL Support

                    Sorry for the delay.

                    No. The logs show a single node without ANK initial config up and running as expected. This is because we are able to configure and start the simulation without issue. The problem is that once the simulation has been configured and Openstack starts each node (virtual machine) unless there is a problem with an Openstack action, we would not see it. When you start the simulation, have looked at your systems resource monitor to see if you physical computer is having a problem with VMware or something?

                    Keep in mind, if your physical computer only has 8GB or RAM and 4 CPUs the slow start would be due to overcommitment of resources. Your CPU has 4 physical cores and is hyperthread enabled, so that would not be a problem. What I do not know is the amount of physical RAM and type of HDD. If your physical computer has 16GB of memory or more, enable RAM disk via UWM System Configuration. Keep me posted.

                    • 7. Re: VIRL CPU Hog errors
                      Federico

                      Hello,

                      My Pc has 16GB of RAM so I don't think memory can be an issue for a single switch.

                      I enabled RAM disk via UWM System Configuration but didn't help.


                      I installed from scratch VMware Player, and VM Maestro, I still have same issue.


                      I was looking around and I have seen couple of posts of people that had same issue after Windows10 Upgrade.

                      Could be? I updated my PC the day before installing Virl.

                      • 8. Re: VIRL CPU Hog errors
                        alejo-VIRL Support

                        It very well could be the Windows update, but this is something we have not been able to replicate. Since rolling back the Windows update may not be the best idea, try installing VMware Workstation (free trial version) and see if the problem persists. Also, while the simulation is starting take a look at the disk activity via System Monitor to ensure the disk does not show high wait times.

                        Can you also post your Windows version including build? Thank you.

                        • 9. Re: VIRL CPU Hog errors
                          Federico

                          Hello,

                          I installed VMWare Pro (trial version) but I still having the same issue.

                          For reference, my Windows10 version is:

                           

                          Windows 10 home

                          Version 1803

                          Build 17134.345

                           

                          Disk activity looks good, it is almost 0

                           

                          Other suggestions?

                           

                          Thank you.

                          • 10. Re: VIRL CPU Hog errors
                            Federico

                            Hello Alejo,

                            any news? for your info yesterday I formatted my PC to factory default, and now I installed again all the files but to Windows 8.1

                            I still have the same issue, so not sure now if could be a specific Windows 10 version.


                            However, I found exactly the same issue here

                            Cisco devices no longer boot within VIRL (Active-Unreachable with slow boot/no prompt)

                            As far as I could see from that post and youtube video posted by Derren, I have the same identical issue.

                             

                            Looks like that problem still ongoing, so I think is not solved yet.

                            • 11. Re: VIRL CPU Hog errors
                              alejo-VIRL Support

                              Hello Federico, the post you are referring to is not exactly the same. One of the issues we saw in the post from Darren is a mismatch of versions. It could have been from a failed upgrade or similar. The CPU hog errors on IOS devices are cosmetic and can be completely ignored. The issue you are describing is related to the virtual machines responding very slow after they have been provisioned. We are just waiting on the virtual machine to boot, but why it is taking so long is what is perplexing. I am still looking into this issue but do not have any answers yet.

                              Can you post a screenshot of 'About VMware' window which can be found under the help menu? This would give me more information so I can attempt to recreate the issue.

                              • 12. Re: VIRL CPU Hog errors
                                Darren

                                I still have the same issue.  I have moved towards netlabs but i would like to find the Virl issue still.

                                 

                                I will try again this week

                                • 13. Re: VIRL CPU Hog errors
                                  Federico

                                  Hi Alejo,

                                  I finally have a god news.

                                  After that I rolled back my laptop to factory default (with Win8.1) I upgraded my windows to 10.


                                  To be more precise current version that I have is:

                                  Windows 10 Home

                                  Version 1803

                                  OS Build 17134.376

                                   

                                  The build is different from the one that I had before formatting my PC, that was Build 17134.345

                                   

                                  With this new version of Windows 10 my simulation is running well.

                                  My L2-SW is booting in about 40 sec while my IOS Router is booting in about 1 minute and 30 sec. and I'm able to access via console without issues.


                                  Now I have one update in pending (Windows is asking me to reboot my laptop to install the update), hopefully this will not break again Virl.


                                  I'll let you know after the upgrade.

                                  • 14. Re: VIRL CPU Hog errors
                                    Federico

                                    Hi Alejo,

                                    I updated my Windows 10 and now simulation does not work anymore.

                                    Is there any investigation about possible windows 10 incompatibilities?

                                     

                                    Thank you

                                    1 2 Previous Next