7 Replies Latest reply: Nov 15, 2019 7:19 AM by jtenke RSS

    Exploring the Various Dial-Plan Methodologies on CUBE - Post Webinar Discussion

    Brett Lovins

      Please consider using this as a post webinar open discussion thread for the webinar on:
      Exploring the Various Dial-Plan Methodologies on CUBE

       

      This webinar took place 2/28/18. We anticipate having the recordings available for on demand viewing by March 8th at the latest.

       

      Register for upcoming Collaboration webinars and review on-demand recordings for this and other sessions here: Collaboration Training Videos

       

      Many thanks to Mihir Pamaraju and Rajarshee Dhar for bringing you this great Collaboration content.

       

      Cheers.

      Brett Lovins

        • 1. Re: Exploring the Various Dial-Plan Methodologies on CUBE - Post Webinar Discussion
          AOS

          This is very useful but it would be great to get a larger sample config that demonstrates each type with benefits and drawbacks so we get better picture of how and when to use each design

          • 2. Re: Exploring the Various Dial-Plan Methodologies on CUBE - Post Webinar Discussion
            Ritesh Desai

            Hi Brett,

             

            Yesterday's session have been informative. Suggestion would be 1 hour was too short and it seemed Cisco team was hurrying up to cover the INDEX.

             

            thanks & regards,

            Ritesh Desai.

            • 3. Re: Exploring the Various Dial-Plan Methodologies on CUBE - Post Webinar Discussion
              wmccluer

              Cubes compress rtp. Below sends pure tone rtp.
              IP Flex Cisco Cubes process the voice.
              CM tones are dropped and call does not go “pure tone”.

              The 1st four dial peers preserve the CM tone (no fax-relay sg3-to-g3) and are for outgoing calls.
              Last two dial peer are for incoming modem dial.
              “show voice call stat” will reveal the number to use in the dial peer and if the number grabbed the dial peers stated

              below.

              Below config is guaranteed to work with:
              Credit card machines
              Pitney Bose Analog Stamp Machines
              Rent-a-car DMV computer
              Medical (EEG and respiratory systems)
              Utility Company meters
              VT-100 maintenance ports

              Dial peers are duplicated for two reasons.

              1. IPFlex router round robins with 2 IP Border Elements
              2. Dial “1” is uncertain if PBX is sending a “1” in front of the number.

              !
              voice class sip-profiles 100
              request REINVITE sdp-header Attribute add "a=silenceSupp:off - - - -"
              !

              !
              dial-peer voice 5071 voip
              destination-pattern 00000-some-phone-number
              modem passthrough protocol codec g711ulaw
              session protocol sipv2
              session target ipv4:IP-address-of-call-processing-device
              voice-class sip profiles 100 inbound
              codec g711ulaw
              fax-relay ecm disable
              no fax-relay sg3-to-g3
              fax nsf 000000
              no vad
              !
              dial-peer voice 5072 voip
              destination-pattern 00000-some-phone-number
              modem passthrough protocol codec g711ulaw
              session protocol sipv2
              session target ipv4:IP-address-of-call-processing-device
              voice-class sip profiles 100 inbound
              codec g711ulaw
              fax-relay ecm disable
              no fax-relay sg3-to-g3
              fax nsf 000000
              no vad
              !
              dial-peer voice 5073 voip
              destination-pattern 00000-some-phone-number
              modem passthrough protocol codec g711ulaw
              session protocol sipv2
              session target ipv4:IP-address-of-call-processing-device
              voice-class sip profiles 100 inbound
              codec g711ulaw
              fax-relay ecm disable
              no fax-relay sg3-to-g3
              fax nsf 000000
              no vad
              !
              dial-peer voice 5074 voip
              destination-pattern 00000-some-phone-number
              modem passthrough protocol codec g711ulaw
              session protocol sipv2
              session target ipv4:IP-address-of-call-processing-device
              voice-class sip profiles 100 inbound
              codec g711ulaw
              fax-relay ecm disable
              no fax-relay sg3-to-g3
              fax nsf 000000
              no vad
              !

              The dial peers below are for incoming calls to be treaded as pure tone to customer modem/device.

              !
              voice class sip-profiles 100
              request REINVITE sdp-header Attribute add "a=silenceSupp:off - - - -"
              !


              dial-peer voice 5075 voip
              description Oxygen Machine
              modem passthrough protocol codec g711ulaw
              incoming called-number 00000-some-phone-number
              voice-class sip profiles 100 inbound
              codec g711ulaw
              fax-relay ecm disable
              no fax-relay sg3-to-g3
              fax nsf 000000
              no vad
              !
              dial-peer voice 5085 voip
              description Gas Company
              modem passthrough protocol codec g711ulaw
              incoming called-number 00000-some-phone-number
              voice-class sip profiles 100 inbound
              codec g711ulaw
              fax-relay ecm disable
              no fax-relay sg3-to-g3
              fax nsf 000000
              no vad
              !

              • 4. Re: Exploring the Various Dial-Plan Methodologies on CUBE - Post Webinar Discussion
                wmccluer

                there is under dial peer

                incoming called-number 00000-some-phone-number

                someone dialing in from the outside.

                and outbound

                destination-pattern 00000-some-phone-number

                and maybe

                answer-address         The Call Destination Number.

                I need to have a dial peer match to wait for an internal phone number to be dialed and apply dial peer parameters.

                What cli config command can open the "from" field from a number out on the LAN/pbx and then find a match to a dial peer?

                I have medical modem calling many numbers and need my above dial-peer applied to it.

                • 5. Re: Exploring the Various Dial-Plan Methodologies on CUBE - Post Webinar Discussion
                  Brett Lovins

                  Here's the Q&A from the session.

                   

                  Q:  Is there any VM version of CUBE ? 

                  A:  CUBE is supported as a virtual feature on CSRs. vCUBE is the naming convention for the same.

                  ________________________________________________________________

                   

                  Q:  Does Cisco support CUBE and SRST on the same router?

                  A:  There were limitation on housing CUBE and SRST on the same router. The development team fixed in 16.7.1 and above. This is the newest version out on CCO at the time of writing of this document and this is currently supported on these newer versions.

                  ________________________________________________________________

                   

                  Q:  What are disadvantages of nanocube?

                  A: There are limitation on the number of SIP sessions from CPU and memory perspective. So the limitation is purely from a plaform / Hardware perspective in handling the number of sessions and Call-per-second.

                   

                  ________________________________________________________________

                   

                  Q:  Does total sessions mean 2 session per call?

                  A: From Cisco's perspective, we define a session as a single call. (2 legs of the same SIP call).

                  ________________________________________________________________

                   

                  Q:  Is a SIP Session 1 SIP Call?  Or 1 Call = 2 SIP Sessions?

                  A:  https://supportforums.cisco.com/sites/default/files/attachments/document/faq_-_cube.pdf

                      Numbers of session refers to the number of SIP calls or IP to IP calls that are traversing via this CUBE.

                      For using the IP to IP gateway feature or CUBE, you need to purchase the required licenses for the number of sessions to handle. So from the licensing perspective a session is equivalent to a call. 

                  ______________________________________________________________

                   

                  Q:  Is the vcube supporting transcoding?

                  A:  No. Because vCUBE is hosted on a virtual environment (UCS and like), it cannot house the hardware DSP resources which are required for transcoding (or any other media resource as well)

                    https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/voice/cube/configuration/cube-book/voi-virtual-cube.pdf

                  ________________________________________________________________

                   

                  Q:  Are CUBE and SRST co-housing on the same device supported now ? (for both SIP/SCCP SRST)

                  A: There were limitation on housing CUBE and SRST (SCCP or SIP) on the same router. The development team fixed in 16.7.1 and above. This is the newest version out on CCO at the time of writing of this document and this is currently supported on these newer versions.

                  ________________________________________________________________

                   

                  Q:  Is the HA configuration different for IOS vs IOS-XE (Since we have other platforms such as ASR where the configuration is different)

                  A:  For that matter, even ISR 4K runs IOS-XE which is the same Operating System as the ASR series platforms. You can avail all the features on ISR 4K as applicable to ASRs as well from the CUBE perspective.

                  The main difference is that with ISR4K and ASR series we implement the High Availability using both box-to-box and within-box redundancy using RG infra.

                  We have a dedicated session for HA on CUBE ISR4k and this would be similar to the ASR platforms as well because both run IOS-XE. For more information refer link below

                  ________________________________________________________________

                   

                  Q:  Do you recommend configuring a catch-all inbound dial-peer?

                  A:  We recommend configuring specific inbound incoming called-number patterns. However usual deployments have a catch-all inbound dial-peer for simplicity. It's a choice between simplicity vs specificity at that point i.e. Incoming called-number.

                    _______________________________________________________________

                   

                  Q:  Can you elaborate on the order of dial-peer execution?

                  A:  This is a verbose answer. You can refer the 2 links below which talks about dial-peer execution order in detail

                  https://www.cisco.com/c/en/us/support/docs/voice/call-routing-dial-plans/14074-in-dial-peer-match.html

                  https://www.cisco.com/c/en/us/support/docs/voice/ip-telephony-voice-over-ip-voip/211306-In-Depth-Explanation-of-Cisco-IOS-and-IO.html

                  ________________________________________________________________

                   

                  Q:  How are dial peers applied if there are two matches, will the more specific match have higher precedence?

                  A:  Specific match is always given higher precedence followed by preference, followed by random match. But you can always change the hunting logic by "dial-peer voice hunt" command globally.(not recommended since this changes the behavior globally for all dial-peers)

                  ________________________________________________________________

                   

                  Q:  I guess that limitation of housing CUBE and SIP SRST on the same router had already been taken care of starting 16.7.1

                  A: The limitation for SRST (both SCCP and SIP_ is covered in 16.7.1. Thanks for your response.

                  ________________________________________________________________

                   

                  Q:  Is dial-peer hunt a global config 

                  A: That is correct. So we need to the global dial-peer hunt command cautiously, as it affects dial-peer hunting at global level.

                  ______________________________________________________________

                   

                  Q:  Can we modify the hunt behavior per 4xx response type?

                  A:  Yes we can. Every 4xx, 5xx response internally creates a cause code for CUBE. CUBE looks at those cause codes and decides whether to hunt or not.   We can change the hunting behavior for these internal cause codes but that is beyond the scope of today's session.

                  As an example the command syntax would be "voice hunt <cause code>".

                  ________________________________________________________________

                   

                  Q:  Is there any demo/trial version virtual cube available for Proof-Of-Concept?

                  A:  We don't have a demo / trial version. But for Proof-Of-Concept, we used dCloud as a platform for customer/partner demos.

                  This is beyond the scope of the discussion today. You can contact the PDI or design advisory team for more information on this.

                  ________________________________________________________________

                   

                  Q:  Can I have to cubes working active-active to load balance?

                  A:  Yes you can load balance but cannot avail high availability at the same time. i.e. you can load balance, but if the call on one active router fail, they will not fall back to the other one. (no high availability / redundancy)   

                  ________________________________________________________________

                   

                  Q:  The WAN ITSP SIP connects to G0/1, so would the VWIC E1 card be freed up after SIP is deployed?

                  A:  That is correct. VWIC are for PRI lines. Once you move to SIP / IP to IP CUBE paradigm, you'll no longer need the PRI lines. But you can keep them as a fall back in case connection to SIP ITSP fails.

                  ________________________________________________________________

                   

                  Q:  Can I have that huntstop on a particular cause code?  

                  A:  Yes. You can explore the "voice hunt" global command that allows you to huntstop for particular cause codes.

                  ________________________________________________________________

                   

                  Q:  What type of failure code routing the call on other dial-peer without hunt

                  A:  By default hunting happens for all cause codes except 3XX. But you can configure these using the "voice hunt" command.

                  ________________________________________________________________

                   

                  Q:  Can we huntstop based on a specific error message "e.g. hunt stop only if we got 404 not found"

                  A:  Yes. Absolutely. voice hunt 1 will do the trick as 404 is mapped to cause code 1  

                  ________________________________________________________________

                   

                  Q:  Hunt stop over rides the preference command?

                  A:  Hunt stop on a dial-peer stop further hunting for another dial-peer. Preference is related to the order of initial dial-peer selection when there are more than 1 match of the same length.

                  ________________________________________________________________

                   

                  Q:  What is RSVP support?

                  A: In newer implementations, Call admission control is done coupled with RSVP to ensure resources are availble prior to the call being signaled out. This is out of the scope of today's webinar.

                    _______________________________________________________________

                   

                  Q:  If you use huntstop and the dial-peer is unavailable, the call cannot complete, correct?  If that is true, is the only advantage of huntstop to speed up the routing of the call?  That almost seems like a negative, given that all it creates is a single point of failure

                  A: Huntstop has a slightly different utility in the sense that, it is used when the session target is known to be NOT reachable irrespective of which dial-peer is used for the call. This means, that we need to send a failure response back to the caller sooner than later (rather than trying all the possible dial-peers out).

                  So it helps to fasten the response times to the caller in this context and also to reduce the overhead on the CUBE to hunt different dial-peer when the session target is known to either be unavailable or unresponsive.

                  ________________________________________________________________

                   

                  Q:  How to correctly check current CPS on CUBE? Can we do this via SNMP?

                  A: You can check these using 2 commands "show sip-ua history stats message-rate" and "show call history stats cps table"

                  ________________________________________________________________

                   

                  Q:  If you have a route list with multiple gateways then will it select the first gateway and thereafter if there are no matching dial-peers then it selects the next gateway or will the call gets dropped?

                  A:  This question pertains more to the CUCM routing behavior. However to answer it, it will select the next available gateway on the route list.

                  ________________________________________________________________

                   

                  Q:  Very often I am faced with issues related to call forward through SIP trunk and ended up using Sip profiles, is there a document that you can point me to explaining the profile creation and testing ? 

                  A:  There is a dedicated webinar session for the same. Please find the details below 

                  ________________________________________________________________

                   

                  Q:  Why do we use incoming called-number . for incoming and not specific number pattern?

                  A:  This is used a a catch-all dial-peer for incoming dial-peer matches to simplify configuration.

                    ________________________________________________________________

                   

                  Q:  Can we route a single incoming calling number to a particular destination (on the PBX side) and route rest the rest of the calling numbers normally?

                  A:  Yes, you can use URI dialing to match specific incoming call based on the calling number, and use dial-peer groups to limit the outgoing dial-peer choices for the call to a particular destination.

                  The other calls that don't match the calling number will get routed normally

                  _____________________________________

                   

                  Q:  So is the request URI the first line in the INVITE?

                  A:  Yes.

                    _______________________________________________________________

                   

                  Q:  How does the huntstop per cause code work?

                  A:  Every 4xx, 5xx response internally creates a cause code for CUBE. CUBE looks at those cause codes and decides whether to hunt or not.   We can change the hunting behavior for these internal cause codes but that is beyond the scope of today's session.

                  As an example the command syntax would be "voice hunt <cause code>".

                  ________________________________________________________________

                   

                  Q:  We are running Cisco ISR4331-CUBE-HA with Verizon as carrier/ITSP, in two weeks we are migrating SIP services to Level 3/CenturyLink – Is there major differences in CUBE configs between both carriers specially Dial-peers,Is there a compatiblity document dial-peers?

                  A:  This is vendor specific and there could be difference in the format of the messages expected. This needs to be analyzed on a case by case basis. i.e. every provider might have specific format expected per customer. So even within the same provider, these need not be consistency of header formats.

                  ________________________________________________________________

                   

                  Q:  We have a integration for Skype for Business with CUBE and CUCM, I need manipulation by script, so my question is: CUBE is the best way scripting for integrate Skype?

                  A:  While we don't state one method is better than another, we recommend using SIP profiles on CUBE to achieve the required manipulation of headers. Another option to explore would be LUA scripting on CUCM.

                    _______________________________________________________________

                   

                  Q:  If I'm matching calls from an ITSP via URI, but I wanted to separate specific calling numbers (to block them for instance), is there a way to do that without doing away with the URI matching for the ITSP?

                  A: Yes. You can match the Dial-peer using VIA URI field and can apply Translation profile (Block) to reject some specific calling numbers. 

                   

                  Q:  CUBE doesn't support HA?  Or doesn't support it in a load balancing scenario?

                  A:  CUBE supports HA. But this means one CUBE is active and other is standby. To loadbalance, you'll need to disable HA. More on this is covered in a dedicated Webinar session for HA specifically.

                  ________________________________________________________________

                   

                  Q:  Questions on "Show call hist/active voice brief" : sometimes call ID's are used more than once? I've seen this command used where all call legs have the same ID even though there are hundreds of call legs. 

                  A:  SIP call-id is unique for every call. This is not the same as the Call leg ID or Call-ID seen in the "show call active voice brief". To clarify, it is possible that some calls have more than 2 call legs on the same router and all these legs will show the same ID.

                  ________________________________________________________________

                   

                  Q:  Can you explain the Answer and Originate values shown on each call leg? Which is inbound? Which is Outbound?

                  A:  Originate is always used for the incoming call leg wherein the calling number is specified and answer is the called party  

                  ________________________________________________________________

                   

                  Q:  I read destination-pattern matches calling number. Should it match called number / dialed string?

                  A:  Destination-pattern matches calling number (least preference in the order), when talking about incoming dial-peer match. Destination-pattern also matches called number but this is true for outgoing dial-peer match.

                  In addition just to clarify, the difference is in the direction of dial-peer matching. What you are saying is true for outgoing dial-peer match.

                  ________________________________________________________________

                   

                  Q:  How can we restrict incoming calls from getting out afterwards? should we configure it via dial-peer groups or can we confige COR?  (Like a loop scenario for e.g.)

                  A:  We can configure cor list definitely. other than that Dial peer provisioning policy as well as well implemented translation profiles can be used  

                  ________________________________________________________________

                   

                  Q:  Can the outbound dial peer be matched based on the inbound dial peer that matched the call? E.g. the CUBE serves two CUCM clusters and communicates two ITSP providers. The CUBE must send calls from CUCM_Cluster_1 to ITSP_1 and from CUCM_Cluster_2 to ITSP_2

                  A:  This can be achieved using dial-peer groups and dial-peer provision policy. Dial-peer groups are simpler in implementation, but have limited option on restricted outgoing match based on incoming dial-peer match. Dial-peer provision policy has more options.  

                  ________________________________________________________________

                   

                  Q:  On those inbound dial-peers 1000 and 2000, I see destination provision-policy command. Shouldn't it should also have incoming uri/called/calling command to match inbound first?

                  A:  Yes, they will be matched first using any of the fields we mentioned earlier, followed by that the Dial peer provisioning will start and match outgoing dial-peers  

                  ________________________________________________________________

                   

                  Q:  I see Voice class uri 20. Where does that come into play VS the voice class provision policy 20?

                  A:  Voice class uri 20 will be matched because the outgoing dial-peer will check this particular URI after checking the dial-peer provisioning policy.

                  ________________________________________________________________

                   

                  Q:  Is there a limitation on how many peer SIP Trunks you can standup with outside companies or partner companies? Or is there a recommended number not to exceed on the ISR 4451?

                  A:  We will conver this when we cover multi tenancy on CUBE. However in terms of dial-peers itself, there is no limitation as far as memory allows the configuration.   

                  ________________________________________________________________

                   

                  Q:  So the dial-peers on the left match by the provision policy, the ones on the right match by voice class?

                  A:  first the incoming dial-peer 2000 will be matched, then the CUBE check the provisioning policy configured, the policy will now restrict what outgoing dial-peers are matched. Once narrowed down the URI voice class is checked to see if the outgoing dial-peer is valid.  

                  ________________________________________________________________

                   

                  Q:  Does the provision-policy use the original inbound SIP Invite i.e. The INVITE before it has gone through digit manipulation on the inbound-dial peer?

                  A: That is correct. The incoming INVITE will be used and cube will not make any changes to the INVITE till the policy provisioning is done completely.

                  ________________________________________________________________

                   

                  Q:  So DPG just groups the dial peers for easy management basically?

                  A:  DPG provides a way for your to restrict outgoing dial-peer matches based on incoming dial-peer matches. So yeah, easy mgmt is one of the outcomes of DPGs.

                  ________________________________________________________________

                   

                  Q:  I see that this is recorded. Will we be emailed a link to get access to that recording so I can rewatch some of this, it's IT Gold :)

                  A:  Yes you will get dropped on a discussion thread with links at the conclusion.  

                  ________________________________________________________________

                   

                  Q:  Will DPG be picked before the actual dialpeer?

                  A: First the incoming INVITE will match an incoming dial-peer. This incoming dial-peer will be mapped to a DPG. The DPG will have a subset of outgoing dial-peer and only these dial-peers can be matched in outgoing direction.

                  ________________________________________________________________

                   

                  Q:  Can we run multiple protocols on CUBE ?

                  A:  Yes. You can have SIP / H.323 on the same CUBE. But for CUBE functionality, you cannot club it with MGCP / SCCP based PRI trunks / analog port configurations. The reason is due to the large number of REGISTER messages that will get punted to the ITSP causing a storm. In view of this and for better design we suggest separating the voice gateways running different protocols to different boxes and keep CUBE unique. 

                  However it is theoretically possible to configure multiple protocols on the device configured as CUBE.  

                  ________________________________________________________________

                   

                  Q:  How fast will it switch the session server group preference, if say Preference 1 server is down?

                  A:  This depends on the time is takes to receive the failure response or no response and realize this is down. Alternatively, you can configure Out of Dialog Options to check the status of server group elements before even trying to signal a call to them.

                   

                  ________________________________________________________________

                   

                  Q:  How is VRF is different from static route?

                  A:  VRF is used to simulate multiple router functionality on one. You can think of it as VLANs at layer 3  

                  ________________________________________________________________

                   

                  Q:  So is the CUBE only going to match dial peers connected to its VRF?

                  A:  Yes. The VRF comes into the picture before the incoming DP match. So it will only match dial-peers associated with this VRF.

                  Whatever interface is bound on the incoming dial-peer is used to check the VRF routing table. So only the dial-peers having binding to interfaces within the same VRF will be looked at for matching. This is true to inbound dial-peers only.

                  ________________________________________________________________

                   

                  Q:  In this example in the presentation, is the CUBE also the MPLS router? 

                  A:  You can co-reside the MPLS / routing functionality on the same CUBE router. In fact in most deployments, the CUBE will also be the MPLS WAN router. In this case you'll have to take care of NATting and other requirements elsewhere i.e co-locating NAT and CUBE on the same box is not recommended.

                  Refer SIP inspection for more details.

                  ________________________________________________________________

                   

                  Q:  So could you have 2 separate dial peers that are the same, but linked to different VRfs?

                  A: Yes, you can.

                  ________________________________________________________________

                   

                  Q:  Is there also a way to keep voice traffic within a VRF, without leaking to other VRF's dial-peers when a route in it's own VRF is not found? So giving a 404 not found instead or using another VRF's route

                  A:  Voice aware vrf is the name of this feature: https://www.cisco.com/c/en/us/td/docs/ios/12_4t/12_4t15/vrfawvgw.html

                  ________________________________________________________________

                   

                  Q:  Can we put bind command globally?

                  A:  You can configure bind globally or even at dial-peer level.

                  ________________________________________________________________

                   

                  Q:  Is VRF used to send calls traffic out certain vrf? In case of incoming calls, it will come in from whichever vrf and that should not matter, right?

                  A:  For outbound routing of the call incoming on a certain vrf, it can use any vrf. This can be controlled though using dial-peer groups.

                    ________________________________________________________________

                   

                  Q:  Is there any Security Guide for CUBE?

                  A:  Here is a link you may find useful.

                  https://www.cisco.com/c/en/us/support/docs/unified-communications/unified-border-element/212057-Configure-Voice-Security-Feature-with-CU.html  

                  ________________________________________________________________

                   

                  Q:  How many VRFs are supported on CUBE ?  How many vrfs can we set per port?

                  A:  You'll find the limiations here : https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/voice/cube/configuration/cube-book/voi-cube-multi-vrf.html 

                  Same link also mentions VRF per port range  

                  ________________________________________________________________

                   

                  Q:  I am looking for a CUBE -HA compatibility document between Cicso and Level 3 / CenturyLink 

                  A:  There is no direct document for this scenario. It is to be investigated on a case by case basis.

                  ________________________________________________________________

                   

                  Q:  Why doesn't "show sip-ua register status" show registered tenants?

                  A: There is an equivalent command for multi-tenancy deployments "show sip-ua register status tenant <X>".

                    ________________________________________________________________

                   

                  Q:  Will CUBE's ever be able to add dial-peers with interface binding for media, with active calls running? ASR's can go upto >10K calls at a time, there will never be moments without active calls.

                  A:  For media there is not requirement to wait until there are no active calls to add the bind commands. This limitation is only for signaling bind. This is because changing signaling binding will affect current calls that have not been established. (i.e calls which are in progress / early dialog and not at final response stage)

                  Currently, there is no way to change signaling bind when there are active calls. We do have an enhancement request and hope to see this in future versions.

                  ________________________________________________________________

                   

                  Q:  Is it possible that MGCP can be used on Multi Tenant Support, say using ISDN PRIs

                  A: If you use MGCP to control your PRIs , you cannot use SIP on the same PRI , however if you use multiple PRI , you can use SIP for those which are not controlled by MGCP.

                  ________________________________________________________________

                   

                  Q:  Hello, is it correct that there is no equivalent to the "show sip-ua register status" with the voice class tenant configuration?

                  A: No. There is an equivalent command "show sip-ua register status tenant <X>".

                  ________________________________________________________________

                   

                  Q:  Tenant option on IOS is available from which version?

                  A: For IOS devices, Multi-tenant feature is available from 15.6(2)T and above. However , they are some challenges on show outputs , so I would recommend to wait for 15.7(3)M2 release which addresses all of them.

                  Whereas for IOs-XE based platforms, it is quite stable and available from 16.3.1 and above.

                  ________________________________________________________________

                   

                  Q:  Some of the advance commands like "voice calls dial-peer, destination provision..." are not accepted on all routers. What version of IOS is needed to be able to do some of the advance commands that were on that presentation?

                  A: Dial-peer provisioning commands are supported  from 15.4(2)T onwards. Here is a link to the feature and the versions supported

                  https://www.cisco.com/c/en/us/support/docs/voice/dial-plan/200103-Configure-and-Troubleshoot-Multiple-Patt.html

                  • 6. Re: Exploring the Various Dial-Plan Methodologies on CUBE - Post Webinar Discussion
                    wmccluer

                    Here is a voip lab to try to build using cisco call manager lite.

                     


                    PSTN (phone line on wall)  404-986-xxxx RINGS 4010 AND 4012 VOIP PHONES
                      |
                    FXO  <<< Lindbergh modem line 404-986-xxxx
                      |
                    C1750
                      |
                    FRAME RELAY SERIAL
                      |    |>>>FASTE0/0 CISCO 7940 VOIP PHONE
                    C3745 CALL MANAGER EXPRESS >>>>>|
                      |          |>>> FXS >>> EXTENTION NUMBER 300X ANALOG PHONE
                    10 MEG ETHERNET
                      |
                    V2611 CALL MANAGER EXPRESS>>>E0/0 CISCO 7940 VOIP PHONE
                      |
                    FXS
                      |
                    EXTENTION NUMBER 800X ANALOG PHONE
                        

                    ******************************************************************************************
                    CISCO 1750 WITH FXO CARD TO PSTN
                         
                    pbx-fxs-demo#wr
                    Building configuration...

                    02:30:17: %SYS-5-CONFIG_I: Configured from console by console[OK]
                    pbx-fxs-demo#sh run
                    Building configuration...

                    Current configuration : 3056 bytes
                    !
                    version 12.3
                    no parser cache
                    service timestamps debug uptime
                    service timestamps log uptime
                    no service password-encryption
                    !
                    hostname pbx-fxs-demo
                    !
                    boot-start-marker
                    boot-end-marker
                    !
                    enable password cisco
                    !
                    memory-size iomem 25
                    no aaa new-model
                    ip subnet-zero
                    !
                    !
                    no ip domain lookup
                    ip host C3745 12.12.12.12
                    ip host v2611 88.88.88.88
                    ip dhcp excluded-address 10.33.33.1
                    !
                    ip cef
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    class-map match-any realtime_ingress
                      match ip dscp ef
                      match access-group 110
                    class-map match-any business_ingress
                      match access-group 130
                    class-map match-any interactive_ingress
                      match access-group 120
                    class-map match-any business_data
                      match ip dscp af21
                      match access-group 130
                    class-map match-any interactive
                      match ip dscp af31
                    class-map match-any voice
                      match ip dscp ef
                    !
                    !
                    policy-map CPE_QOS_INGRESS_LAN
                      class realtime_ingress
                       set ip dscp ef
                      class interactive_ingress
                       set ip dscp af41
                      class business_ingress
                       set ip dscp af21
                    policy-map CPE_qos
                      class voice
                       priority percent 25
                       police cir percent 25
                         conform-action transmit
                         exceed-action transmit
                      class class-default
                       bandwidth percent 10
                       police cir percent 10
                         conform-action transmit
                         exceed-action transmit
                    !
                    !
                    !
                    interface Loopback0
                    ip address 10.200.200.200 255.255.255.0
                    h323-gateway voip bind srcaddr 10.200.200.200
                    !
                    interface FastEthernet0
                    no ip address
                    speed 100
                    full-duplex
                    !
                    interface Serial0
                    no ip address
                    encapsulation frame-relay IETF
                    frame-relay lmi-type ansi
                    service-policy output CPE_qos
                    !        
                    interface Serial0.701 point-to-point
                    ip address 10.240.0.254 255.255.255.0
                    frame-relay interface-dlci 701  
                    !
                    interface Serial1
                    no ip address
                    shutdown
                    !
                    router eigrp 100
                    redistribute connected
                    network 10.0.0.0
                    no auto-summary
                    !
                    ip classless
                    ip route 0.0.0.0 0.0.0.0 10.240.0.1
                    ip http server
                    ip http path flash
                    !
                    !
                    !
                    tftp-server flash:sepdefault.cnf
                    tftp-server flash:p003d302.bin
                    tftp-server flash:p004d302.bin
                    snmp-server manager
                    !
                    !
                    voice-port 2/0
                    connection plar 9860330
                    !
                    voice-port 2/1
                    !
                    dial-peer cor custom
                    !
                    !
                    !
                    dial-peer voice 8888 voip
                    destination-pattern 8...
                    session target ipv4:88.88.88.88
                    dtmf-relay h245-alphanumeric
                    codec g711ulaw
                    no vad
                    !
                    dial-peer voice 3333 voip
                    destination-pattern 3...
                    session target ipv4:12.12.12.12
                    dtmf-relay h245-alphanumeric
                    codec g711ulaw
                    no vad
                    !
                    dial-peer voice 2000 pots
                    incoming called-number .
                    destination-pattern 999[2-9]..[2-9]......
                    port 2/0
                    forward-digits 12
                    !
                    dial-peer voice 9860330 voip
                    incoming called-number .
                    destination-pattern 9860330
                    session target ipv4:12.12.12.12
                    dtmf-relay h245-alphanumeric
                    codec g711ulaw
                    no vad
                    !
                    dial-peer voice 4444 voip
                    destination-pattern 4...
                    session target ipv4:12.12.12.12
                    dtmf-relay h245-alphanumeric
                    codec g711ulaw
                    no vad  
                    !
                    alias exec all show ip int brie
                    alias exec vstat show voice call stat
                    alias exec vsum show voice call summary
                    alias exec big show call active voice
                    !
                    line con 0
                    privilege level 15
                    line aux 0
                    line vty 0 4
                    privilege level 15
                    password cisco
                    login
                    !
                    end

                    pbx-fxs-demo

                    ***************************************************************************
                    CISCO 2611 WITH DUAL 10 MEG ETHERNET, FXS AND CALL MANAGER EXPRESS


                    VOIP PHONE VIA IP HELPER GETTING LOAD FROM CISCO 3745

                    NEED 64MB DRAM,  32 MEG FLASH FOR PHONE FILES, CISCO 2621 WITH DUAL FASTE'S

                    with NM-1V voice module ($35 on ebay) and FXS/PHONE or FXO/PSTN ($45 on ebay)
                    2621 ($50 to $80)


                    V2611#sh fla

                    System flash directory:
                    File  Length   Name/status
                      1   15514236  c2600-is5-mz.123-26.bin  << NEED 64MB DRAM TO RUN
                    [15514300 bytes used, 738624 available, 16252924 total]
                    16384K bytes of processor board System flash (Read/Write)

                    V2611#sh run
                    Building configuration...

                    Current configuration : 2351 bytes
                    !
                    version 12.3
                    service timestamps debug datetime msec
                    service timestamps log datetime msec
                    no service password-encryption
                    !
                    hostname V2611
                    !
                    boot-start-marker
                    boot-end-marker
                    !
                    logging buffered 4096 debugging
                    !
                    no aaa new-model
                    ip subnet-zero
                    ip cef
                    !
                    !
                    ip host C3745 12.12.12.12
                    !
                    ip dhcp pool mac
                       network 192.168.3.0 255.255.255.0
                       default-router 192.168.3.1
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    interface Loopback88
                    ip address 88.88.88.88 255.255.255.255
                    h323-gateway voip bind srcaddr 88.88.88.88
                    !
                    interface Ethernet0/0
                    ip address 10.70.0.1 255.255.255.0
                    ip helper-address 12.12.12.12
                    half-duplex
                    !
                    interface Serial0/0
                    no ip address
                    shutdown
                    no fair-queue
                    !
                    interface Ethernet0/1
                    ip address 10.170.0.254 255.255.255.0
                    full-duplex
                    !
                    interface Serial0/1
                    no ip address
                    shutdown
                    !
                    router eigrp 100
                    redistribute connected
                    network 10.0.0.0
                    network 88.0.0.0
                    no auto-summary
                    !        
                    ip http server
                    ip classless
                    !
                    !
                    !
                    !
                    voice-port 1/0/0
                    !
                    voice-port 1/0/1
                    !
                    !
                    !
                    dial-peer voice 8001 pots
                    destination-pattern 8001
                    port 1/0/0
                    !
                    dial-peer voice 8002 pots
                    destination-pattern 8002
                    port 1/0/1
                    !
                    dial-peer voice 2000 voip
                    incoming called-number .
                    destination-pattern 999[2-9]..[2-9]......
                    session target ipv4:10.200.200.200
                    dtmf-relay h245-alphanumeric
                    codec g711ulaw
                    no vad
                    !
                    dial-peer voice 3333 voip
                    destination-pattern 3...
                    session target ipv4:12.12.12.12
                    dtmf-relay h245-alphanumeric
                    codec g711ulaw
                    no vad
                    !
                    dial-peer voice 4444 voip
                    destination-pattern 4...
                    session target ipv4:12.12.12.12
                    dtmf-relay h245-alphanumeric
                    codec g711ulaw
                    no vad
                    !
                    !
                    telephony-service
                    load 7910 P00307020400
                    load 7960-7940 P00308000100
                    max-ephones 48
                    max-dn 192
                    create cnf-files
                    ip source-address 10.70.0.1 port 2000
                    voicemail 8002
                    !
                    !
                    ephone-dn  1
                    number 8010
                    !
                    !
                    ephone-dn  2
                    number 8012
                    !
                    !
                    ephone  1
                    mac-address 0009.E830.1FD4
                    speed-dial 1 3001 label "C2611_3001"
                    button  1:1 2:2
                    !
                    !
                    !
                    !
                    ephone  2
                    mac-address 000A.F489.91F6
                    speed-dial 1 8001 label "V2611_8001"
                    button  1:1 2:2
                    !
                    !
                    !
                    !
                    ephone  3
                    !
                    !
                    !
                    alias exec sq show ip route
                    alias exec big show call active voice
                    alias exec vstat show voice call stat
                    alias exec vsum show voice call summary
                    alias exec all show ip int brie
                    alias exec rr show ip bgp neighbor 12.50.50.49 route
                    !
                    line con 0
                    privilege level 15
                    line aux 0
                    line vty 0 4
                    privilege level 15
                    password cisco
                    login
                    !
                    !
                    end

                     

                     

                    ******************************************************************************
                    CISCO 3745 WITH FXS AND VOIP PHONES running CALL MANAGER EXPRESS

                    FIRMWARE IS HERE

                    C3745#SH FLA
                    -#- --length-- -----date/time------ path
                    1     30261568 Mar 1 2002 00:22:10 +00:00 c3745-ipvoice-mz.124-16.bin
                    2       129476 Mar 1 2002 00:33:20 +00:00 P00307020400.bin
                    3          459 Mar 1 2002 00:33:38 +00:00 P00307020400.loads
                    4       685390 Mar 1 2002 00:33:52 +00:00 P00307020400.sb2
                    5       129880 Mar 1 2002 00:34:06 +00:00 P00307020400.sbn
                    6       129496 Mar 1 2002 00:34:24 +00:00 P00308000100.bin
                    7          461 Mar 1 2002 00:34:36 +00:00 P00308000100.loads
                    8       699878 Mar 1 2002 00:34:50 +00:00 P00308000100.sb2
                    9       129900 Mar 1 2002 00:35:02 +00:00 P00308000100.sbn

                    31825920 bytes available (32186368 bytes used)

                    C3745#


                    C3745#s run
                    Building configuration...

                    Current configuration : 5509 bytes
                    !
                    version 12.4
                    service timestamps debug datetime msec
                    service timestamps log datetime msec
                    no service password-encryption
                    !
                    hostname C3745
                    !
                    boot-start-marker
                    boot-end-marker
                    !
                    logging buffered 4096 debugging
                    enable password cisco
                    !
                    no aaa new-model
                    ip cef
                    !
                    !
                    no ip dhcp use vrf connected
                    ip dhcp excluded-address 10.70.0.1
                    ip dhcp excluded-address 10.60.0.1
                    !        
                    ip dhcp pool sixty
                       network 10.60.0.0 255.255.255.0
                       default-router 10.60.0.1
                       dns-server 205.152.37.23 205.152.132.23
                       netbios-name-server 10.60.0.200
                       option 150 ip 10.60.0.1
                    !
                    ip dhcp pool seventy
                       network 10.70.0.0 255.255.255.0
                       default-router 10.70.0.1
                       dns-server 205.152.37.23 205.152.132.23
                       netbios-name-server 10.70.0.200
                       option 150 ip 10.70.0.1
                    !
                    !
                    no ip domain lookup
                    ip host C1750 10.200.200.200
                    ip host V2611 88.88.88.88
                    ip host c28 192.168.3.1
                    ip host c17 10.60.0.70
                    ip host tip 12.50.50.49
                    ip host bot 124.124.124.2
                    ip host grey 12.50.50.49
                    ip host yellow 124.124.124.2
                    ip host gray 12.50.50.49
                    ip host cat 222.222.222.2
                    ip host csu 192.0.2.1
                    ip host top 122.122.122.2
                    ip host mid 120.120.120.1
                    ip host mids56 12.12.12.1
                    frame-relay switching
                    !
                    !
                    key chain cisco
                    key 1
                       key-string mac
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !
                    !        
                    !
                    fax interface-type fax-mail
                    !
                    !
                    controller T1 1/0
                    framing esf
                    linecode b8zs
                    channel-group 0 timeslots 1-24 speed 64
                    !
                    controller T1 1/1
                    framing esf
                    linecode b8zs
                    channel-group 0 timeslots 1-24 speed 64
                    !
                    !
                    class-map match-any realtime_ingress
                    match ip dscp ef
                    match access-group 110
                    class-map match-any business_ingress
                    match access-group 130
                    class-map match-any interactive_ingress
                    match access-group 120
                    class-map match-any business_data
                    match ip dscp af21
                    match access-group 130
                    class-map match-any interactive
                    match ip dscp af31
                    class-map match-any voice
                    match ip dscp ef
                    !
                    !
                    policy-map CPE_QOS_INGRESS_LAN
                    class realtime_ingress
                      set ip dscp ef
                    class interactive_ingress
                      set ip dscp af41
                    class business_ingress
                      set ip dscp af21
                    policy-map CPE_qos
                    class voice
                      priority percent 25
                       police cir percent 25
                         conform-action transmit
                         exceed-action transmit
                    class class-default
                      bandwidth percent 10
                       police cir percent 10
                         conform-action transmit
                         exceed-action transmit
                    !
                    !
                    !
                    !
                    interface Loopback12
                    ip address 12.12.12.12 255.255.255.255
                    h323-gateway voip bind srcaddr 12.12.12.12
                    !
                    interface Loopback192168
                    ip address 192.168.180.12 255.255.255.255
                    !
                    interface FastEthernet0/0
                    ip address 10.60.0.1 255.255.255.0
                    load-interval 30
                    duplex auto
                    speed 10
                    !
                    interface Serial0/0
                    no ip address
                    encapsulation frame-relay IETF
                    no fair-queue
                    frame-relay lmi-type ansi
                    !
                    interface Serial0/0.701 point-to-point
                    ip address 10.240.0.1 255.255.255.0
                    frame-relay interface-dlci 701  
                    !
                    interface FastEthernet0/1
                    ip address 10.170.0.1 255.255.255.0
                    speed 10
                    full-duplex
                    auto qos voip trust
                    !
                    interface Serial1/0:0
                    no ip address
                    encapsulation frame-relay IETF
                    frame-relay lmi-type ansi
                    frame-relay intf-type dce
                    frame-relay route 701 interface Serial1/1:0 701
                    !
                    interface Serial1/1:0
                    no ip address
                    encapsulation frame-relay IETF
                    frame-relay lmi-type ansi
                    frame-relay intf-type dce
                    frame-relay route 701 interface Serial1/0:0 701
                    !
                    router eigrp 100
                    redistribute connected
                    network 10.0.0.0
                    network 12.0.0.0
                    network 192.168.180.0
                    no auto-summary
                    !
                    !
                    ip http server
                    !
                    access-list 48 permit 100.100.100.24 log
                    access-list 48 deny   12.50.50.0 0.0.0.255
                    access-list 148 deny   ip 12.50.50.0 0.0.0.255 any
                    access-list 151 permit ip any any
                    !
                    !
                    tftp-server flash:P00307020400.bin
                    tftp-server flash:P00307020400.loads
                    tftp-server flash:P00307020400.sb2
                    tftp-server flash:P00307020400.sbn
                    tftp-server flash:P00308000100.bin
                    tftp-server flash:P00308000100.loads
                    tftp-server flash:P00308000100.sb2
                    tftp-server flash:P00308000100.sbn
                    !
                    control-plane
                    !
                    rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS
                    !
                    !
                    voice-port 3/0/0
                    !
                    voice-port 3/0/1
                    !
                    !
                    !
                    !
                    !
                    dial-peer voice 3001 pots
                    destination-pattern 3001
                    port 3/0/0
                    !
                    dial-peer voice 3002 pots
                    destination-pattern 3002
                    port 3/0/1
                    !
                    dial-peer voice 2000 voip
                    destination-pattern 999[2-9]..[2-9]......
                    session target ipv4:10.200.200.200
                    incoming called-number .
                    dtmf-relay h245-alphanumeric
                    codec g711ulaw
                    no vad
                    !
                    dial-peer voice 8888 voip
                    destination-pattern 8...
                    session target ipv4:88.88.88.88
                    dtmf-relay h245-alphanumeric
                    codec g711ulaw
                    no vad
                    !
                    !
                    telephony-service
                    load 7910 P00307020400
                    load 7960-7940 P00308000100
                    max-ephones 48
                    max-dn 192
                    ip source-address 10.60.0.1 port 2000
                    create cnf-files
                    voicemail 3002
                    max-conferences 8 gain -6
                    !
                    !
                    ephone-dn  1
                    number 4010
                    !
                    !
                    ephone-dn  2
                    number 4012
                    !
                    !
                    ephone  1
                    description Cisco 7940 connected to Cisco 3745
                    mac-address 000A.F489.91F6
                    speed-dial 1 8001 label "V2611_8001"
                    button  1:1 2:2
                    !
                    !        
                    !
                    ephone  2
                    mac-address 0009.E830.1FD4
                    speed-dial 1 3001 label "C2611_3001"
                    button  1:1 2:2
                    !
                    !
                    ephone-hunt 1 sequential
                    pilot 9860330
                    list 4010, 4012
                    timeout 4
                    !
                    !
                    alias exec sq show ip route
                    alias exec big show call active voice
                    alias exec vstat show voice call stat
                    alias exec vsum show voice call summary
                    alias exec all show ip int brie
                    alias exec rr show ip bgp neighbor 12.50.50.49 route
                    !
                    line con 0
                    privilege level 15
                    transport output all
                    line aux 0
                    transport output all
                    line vty 0 4
                    privilege level 15
                    password cisco
                    login
                    length 0
                    transport input all
                    transport output all
                    line vty 5 15
                    password cisco
                    login
                    transport input all
                    transport output all
                    !
                    !
                    end

                     

                    **************************************************************************

                    converstation with cisco

                     


                    IP phone >>>2611CME>>VoIP>>>3745>>FXO>>PSTN

                    PSTN>>>FXO>>>3745>>>VoIP>>>2611CME>>> IP phone

                    Outbound call


                    2611 CME

                    dial-peer voice 1000 voip
                    destination-pattern 9[2-9]..[2-9]......
                    session target ipv4:12.12.12.12 >>3745
                    codec g711ulaw
                    dtmf-relay h245-alphanumeric
                    no vad
                    incoming called-number .

                    voice hunt-group 10 sequential
                    pilot 555
                    list 8001,8002,3001,3002
                    timeout 20

                     

                    3745 CME

                    dial-peer voice 1000 voip
                    destination-pattern 555
                    session target ipv4:88.88.88.88 >> 2611 IP
                    incoming called-number .
                    codec g711ulaw
                    dtmf-relay h245-alpha
                    no vad

                    dial-peer voice 2000 pots
                    destination-pattern 9[2-9]..[2-9]......
                    ! port <fxo port #>
                    forward-digits 10
                    incoming called-number .


                    voice-port <fxo port #>
                    connection plar 555

                     

                    IP phone >>>3745 CME

                     

                    The fact you cannot configure a voice hunt may be because of the CME version, instead of using a voice hunt-group try using the following configuration

                    config t
                    ephone-hunt 1 sequential
                    pilot 8000
                    list 8001, 8002, 8003


                    This will create a sequential hunt group using 8000 as the pilot number and ringing extension 8001, 8002 and 8003 in a sequential order. Do not copy/paste the configuration if these extensions are not valid, this is just an example of how you can setup your own ephone-hunt, you can change the extensions and pilot number to something that adjust to your congiuration.

                     

                     

                     

                     

                     

                     

                    *********************************

                    • 7. Re: Exploring the Various Dial-Plan Methodologies on CUBE - Post Webinar Discussion
                      jtenke

                      Hi! Team,

                      Could you please share the recording video of this training?

                       

                      Rgds,