1 Reply Latest reply: Feb 7, 2018 12:02 PM by Steven Davidson RSS

    hosts on different trunks unable to communicate with each other

    George

      I can communicate with both hosts from a management workstation on vlan 1, but the host cannot communicate with each other. Can you help me figure out what I have done wrong?

      These are my two hosts (ESXi1 and ESXi2), one in Port-channel11 and one in Port-channel12:

      WS-C3750G-24T#show ip arp vlan 8

      Protocol  Address          Age (min)  Hardware Addr   Type   Interface

      Internet  192.168.8.1             0   68b5.99b7.6660  ARPA   Vlan8

      Internet  192.168.8.2             0   1cc1.de6f.132c  ARPA   Vlan8

      all showing connected

      WS-C3750G-24T#sh ip route

      Codes: C - connected, S - static...

      Gateway of last resort is 192.168.1.254 to network 0.0.0.0

      C    192.168.8.0/24 is directly connected, Vlan8

      C    192.168.9.0/24 is directly connected, Vlan9

      C    192.168.10.0/24 is directly connected, Vlan10

      C    192.168.11.0/24 is directly connected, Vlan11

      C    192.168.7.0/24 is directly connected, Vlan7

      C    192.168.1.0/24 is directly connected, Vlan1

      S*   0.0.0.0/0 [1/0] via 192.168.1.25

      full config

      WS-C3750G-24T#sh run

      Building configuration...

       

       

      Current configuration : 6348 bytes

      !

      ! Last configuration change at 19:09:57 GMT Wed Feb 7 2018 by root

      !

      version 12.2

      no service pad

      service timestamps debug uptime

      service timestamps log uptime

      service password-encryption

      !

      hostname WS-C3750G-24T

      !

      enable secret 5 $1$H1dR$Bf.0vjTb90JPRxm7gEs7k1

      enable password 7 02250D480809

      !

      username root privilege 15 secret 5 $1$n7KW$jMj6mdCrKIz2wEhoIW1Ai/

      no aaa new-model

      clock timezone GMT 0

      clock summer-time GMT recurring last Sun Mar 1:00 last Sun Oct 2:00

      switch 1 provision ws-c3750g-24t

      ip subnet-zero

      ip routing

      ip domain-name lab.local

      ip name-server 8.8.8.8

      !

      ip ssh version 2

      !

      !

      crypto pki trustpoint TP-self-signed-2144210688

      enrollment selfsigned

      subject-name cn=IOS-Self-Signed-Certificate-2144210688

      revocation-check none

      rsakeypair TP-self-signed-2144210688

      !

      !

      crypto ca certificate chain TP-self-signed-2144210688

      certificate self-signed 01

        3082029F 30820208 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

        59312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

        69666963 6174652D 32313434 32313036 38383126 30240609 2A864886 F70D0109

        02161757 532D4333 37353047 2D323454 2E6C6162 2E6C6F63 616C301E 170D3933

        30333031 30303031 34325A17 0D323030 31303130 30303030 305A3059 312F302D

        06035504 03132649 4F532D53 656C662D 5369676E 65642D43 65727469 66696361

        74652D32 31343432 31303638 38312630 2406092A 864886F7 0D010902 16175753

        2D433337 3530472D 3234542E 6C61622E 6C6F6361 6C30819F 300D0609 2A864886

        F70D0101 01050003 818D0030 81890281 8100BDC7 03AC09CB 08CA435E 81F5B357

        080DC054 733E690D 0C9EE9CD 1CBFE8B0 22426FF5 D491FA9A 90DD9A60 1055EA07

        977EAB6D DB3D9811 3E4B0CDC 5A8BB24C 9E9A7874 9D9197FB AC82F12F 1A46257E

        D985BF37 065FA66F D3CF9320 F9D09B63 FE88758F 52FBA829 60E3D7BC CBDA20B6

        E392DC68 2358009C DC44DCF2 E71EA2E1 589B0203 010001A3 77307530 0F060355

        1D130101 FF040530 030101FF 30220603 551D1104 1B301982 1757532D 43333735

        30472D32 34542E6C 61622E6C 6F63616C 301F0603 551D2304 18301680 14BA0E82

        3DBFCE53 1E584160 56E9A9B3 3C26485B C0301D06 03551D0E 04160414 BA0E823D

        BFCE531E 58416056 E9A9B33C 26485BC0 300D0609 2A864886 F70D0101 04050003

        8181004E 6360C9A8 78DC9A9A C47DBF5C FCD4AF97 F66402BE B672647A 1C96F458

        9D42A78A 1B92A461 D92D147C AC1B1752 09A2FA76 8CFD56ED B08AB3C0 14775216

        B8EE1FC7 AC86C458 F8FEEA2A 0CE02DF7 0CDA867A 08C05D8D EB61D937 AC028216

        98B238D7 FF209EB3 FF01480A 0BF8362D D7B30793 F41BD43A E168E911 DB328FA4 FF0985

        quit

      !

      !

      no file verify auto

      spanning-tree mode pvst

      spanning-tree extend system-id

      !

      vlan internal allocation policy ascending

      !

      interface Port-channel1

      description description QNAP NAS EtherChannel1

      switchport access vlan 10

      switchport mode access

      !

      interface Port-channel2

      description description QNAP NAS EtherChannel2

      switchport access vlan 11

      switchport mode access

      !

      interface Port-channel11

      description ESXi1

      switchport trunk encapsulation dot1q

      switchport mode trunk

      switchport nonegotiate

      spanning-tree portfast trunk

      !

      interface Port-channel12

      description ESXi2

      switchport trunk encapsulation dot1q

      switchport mode trunk

      switchport nonegotiate

      spanning-tree portfast trunk

      !

      interface GigabitEthernet1/0/1

      description ESXi1

      switchport trunk encapsulation dot1q

      switchport mode trunk

      switchport nonegotiate

      channel-group 11 mode on

      spanning-tree portfast trunk

      !

      interface GigabitEthernet1/0/2

      description esxi1-ilo

      !

      interface GigabitEthernet1/0/3

      description ESXi1

      switchport trunk encapsulation dot1q

      switchport mode trunk

      switchport nonegotiate

      channel-group 11 mode on

      spanning-tree portfast trunk

      !

      interface GigabitEthernet1/0/4

      shutdown

      !

      interface GigabitEthernet1/0/5

      description ESXi2

      switchport trunk encapsulation dot1q

      switchport mode trunk

      switchport nonegotiate

      channel-group 12 mode on

      spanning-tree portfast trunk

      !

      interface GigabitEthernet1/0/6

      description esxi2-ilo

      !

      interface GigabitEthernet1/0/7

      description ESXi2

      switchport trunk encapsulation dot1q

      switchport mode trunk

      switchport nonegotiate

      channel-group 12 mode on

      spanning-tree portfast trunk

      !

      interface GigabitEthernet1/0/8

      shutdown

      !

      interface GigabitEthernet1/0/9

      shutdown

      !

      interface GigabitEthernet1/0/10

      shutdown

      !

      interface GigabitEthernet1/0/11

      shutdown

      !

      interface GigabitEthernet1/0/12

      shutdown

      !

      interface GigabitEthernet1/0/13

      shutdown

      !

      interface GigabitEthernet1/0/14

      shutdown

      !

      interface GigabitEthernet1/0/15

      shutdown

      !

      interface GigabitEthernet1/0/16

      shutdown

      !

      interface GigabitEthernet1/0/17

      description QNAP NAS1

      switchport access vlan 10

      switchport mode access

      channel-group 1 mode active

      spanning-tree portfast

      !

      interface GigabitEthernet1/0/18

      description QNAP NAS2

      switchport access vlan 10

      switchport mode access

      channel-group 1 mode active

      spanning-tree portfast

      !

      interface GigabitEthernet1/0/19

      shutdown

      !

      interface GigabitEthernet1/0/20

      shutdown

      !

      interface GigabitEthernet1/0/21

      description QNAP NAS3

      switchport access vlan 11

      switchport mode access

      channel-group 2 mode active

      spanning-tree portfast

      !

      interface GigabitEthernet1/0/22

      description QNAP NAS4

      switchport access vlan 11

      switchport mode access

      channel-group 2 mode active

      spanning-tree portfast

      !

      interface GigabitEthernet1/0/23

      shutdown

      !

      interface GigabitEthernet1/0/24

      description uplink

      switchport mode access

      !

      interface Vlan1

      description BT_Infinity

      ip address 192.168.1.200 255.255.255.0

      !

      interface Vlan7

      description MGMT

      ip address 192.168.7.200 255.255.255.0

      !

      interface Vlan8

      description ESXi

      ip address 192.168.8.200 255.255.255.0

      !

      interface Vlan9

      description NSX

      ip address 192.168.9.200 255.255.255.0

      !

      interface Vlan10

      description Storage NFS1

      ip address 192.168.10.200 255.255.255.0

      !

      interface Vlan11

      description Storage NFS2

      ip address 192.168.11.200 255.255.255.0

      !

      ip classless

      ip route 0.0.0.0 0.0.0.0 192.168.1.254

      ip http server

      ip http secure-server

      !

      snmp-server community MySnMpsTr! RO

      snmp-server location lab

      snmp-server contact me

      !

      control-plane

      !

      banner login ^C Access for authorized users only. Please enter your username and password. ^C

      !

      line con 0

      line vty 0 4

      exec-timeout 15 0

      password 7 0822455D0A16

      login local

      transport input ssh

      line vty 5 15

      password 7 094F471A1A0A

      no login

      !

      ntp clock-period 36029455

      ntp server 193.150.34.2 prefer

      ntp server 217.114.59.3 prefer

      end

       

       

      WS-C3750G-24T#

      switch version

      Switch   Ports  Model              SW Version              SW Image           

      ------   -----  -----              ----------              ----------         

      *    1   24     WS-C3750G-24T      12.2(25)SEE4            C3750-IPBASEK9-