13 Replies Latest reply: Apr 23, 2019 10:12 AM by Naresh Myaka RSS

    Multicast Routing on NX-OS within vrf

    gavsparks

      Hi,

      I'm testing a scenario where I require Multicast routing over a Leaf/Spine infrastructure.

      At present it is a simple topology. 3 switches 1 spine 2 leaf's 93180YC-EX running NX-OS 7.0.3.I4.6

       

      The SPINE is the RP and is statically assigned on all 3 switches within the VRF.  On each switch I have a loopback interface with a unique IP that is part of OSPF and has joined the multicast group 224.1.2.3.

       

      However if I issue the following from the spine I get no response:

       

      ping multicast 224.1.2.3 interface lo0 vrf VRF_RED source 192.168.0.254

       

      Any ideas what is missing ???

       

      SPINE# sh ip mroute vrf VRF_RED
      IP Multicast Routing Table for VRF "VRF_RED"

      (*, 224.1.2.3/32), uptime: 00:01:11, pim ip
        Incoming interface: loopback0, RPF nbr: 192.168.0.254, uptime: 00:01:11
        Outgoing interface list: (count: 2)
          Ethernet1/5.1, uptime: 00:00:49, pim
          Ethernet1/2.1, uptime: 00:01:11, pim

      (*, 232.0.0.0/8), uptime: 00:15:35, pim ip
        Incoming interface: Null, RPF nbr: 0.0.0.0, uptime: 00:15:35
        Outgoing interface list: (count: 0)

       

       

       

      Config:

       

      vrf context VRF_RED

        ip pim rp-address 192.168.0.254 group-list 224.0.0.0/9

        ip pim ssm range 232.0.0.0/8

       

      eg:

      Leaf A.

      nterface Ethernet1/47.1

        mtu 9216

        encapsulation dot1q 101

        vrf member VRF_RED

        bfd interval 500 min_rx 500 multiplier 5

        no ip redirects

        ip address 192.168.2.1/31

      ip ospf network point-to-point

        ip router ospf 1 area 0.0.0.0

        ip ospf bfd

        ip pim sparse-mode

        no shutdown

       

      interface loopback0

        vrf member VRF_RED

        ip address 192.168.0.251/32

        ip router ospf 1 area 0.0.0.0

        ip pim sparse-mode

      ip igmp join-group 224.1.2.3

       

       

      Leaf B.

       

      interface Ethernet1/47.1

        mtu 9216

        encapsulation dot1q 101

        vrf member VRF_RED

        bfd interval 500 min_rx 500 multiplier 3

      no ip redirects

        ip address 192.168.2.5/31

      p ospf network point-to-point

        ip router ospf 1 area 0.0.0.0

        ip ospf bfd

        ip pim sparse-mode

        no shutdown

       

      interface loopback0

        vrf member VRF_RED

        ip address 192.168.0.252/32

        ip router ospf 1 area 0.0.0.0

        ip pim sparse-mode

      ip igmp join-group 224.1.2.3

       

      Spine

       

      interface Ethernet1/3.1

        mtu 9216

        encapsulation dot1q 101

        vrf member VRF_RED

        bfd interval 500 min_rx 500 multiplier 3

        no ip redirects

        ip address 192.168.2.0/31

      ip ospf network point-to-point

        ip router ospf 1 area 0.0.0.0

        ip ospf bfd

        ip pim sparse-mode

        ip pim dr-priority 255

        no shutdown

       

       

      interface Ethernet1/5.1

        mtu 9216

        encapsulation dot1q 101

        vrf member VRF_RED

        bfd interval 500 min_rx 500 multiplier 3

        no ip redirects

        ip address 192.168.2.4/31

      ip ospf network point-to-point

        ip router ospf 1 area 0.0.0.0

        ip ospf bfd

        ip pim sparse-mode

        ip pim dr-priority 255

        no shutdown

       

      interface loopback0

        vrf member VRF_RED

        ip address 192.168.0.254/32

        ip router ospf 1 area 0.0.0.0

        ip pim sparse-mode

         
        • 1. Re: Multicast Routing on NX-OS within vrf
          Sergey

          gavsparks,

           

          First thing you need to check is whether the PIM neighbour relationships are established between leafs and spine. Can you please provide output of "show ip pim neighbor vrf VRF_RED" from all 3 switches.

          Second thing is to make sure all of them agree on an RP address. "show ip pim rp vrf VRF_RED".

          That's assuming the unicast routing is all in good order

          • 2. Re: Multicast Routing on NX-OS within vrf
            gavsparks

            Hi,

            PIM neighborship are all up and they all agree on the RP. I think it is something about the ping "multicast" key word.

            I have also noticed that if I use an extended ping eg:

            ping (enter)

            vrf context to use [default]: VRF_RED

            Target IP address or Hostname 224.1.2.3

            All the defaults for rest of the questions

             

            I get replies.

             

            So it must be something about the ping multicast command I don't understand.

             

            (SPINE)

            PIM Neighbor Status for VRF "VRF_RED"

            Neighbor        Interface            Uptime    Expires   DR       Bidir-  BFD

                                                                     Priority Capable State

            192.168.2.9     Ethernet1/2.1        20:32:04  00:01:18  1        yes     n/a

            192.168.2.1     Ethernet1/3.1        20:32:05  00:01:25  1        yes     n/a

            192.168.2.5     Ethernet1/5.1        20:31:35  00:01:20  1        yes     n/a

            192.168.2.7     Ethernet1/6.1        20:31:35  00:01:36  1        yes     n/a

             

            LEAF A# sh ip pim rp vrf VRF_RED
            PIM RP Status Information for VRF "VRF_RED"
            BSR disabled
            Auto-RP disabled
            BSR RP Candidate policy: None
            BSR RP policy: None
            Auto-RP Announce policy: None
            Auto-RP Discovery policy: None

            RP: 192.168.0.254, (0), uptime: 01:32:27, expires: never,
              priority: 0, RP-source: (local), group ranges

             

            LEAF B# sh ip pim rp vrf VRF_RED
            PIM RP Status Information for VRF "VRF_RED"
            BSR disabled
            Auto-RP disabled
            BSR RP Candidate policy: None
            BSR RP policy: None
            Auto-RP Announce policy: None
            Auto-RP Discovery policy: None

            RP: 192.168.0.254, (0), uptime: 01:32:57, expires: never,
              priority: 0, RP-source: (local), group ranges:
                  224.0.0.0/9

            • 3. Re: Multicast Routing on NX-OS within vrf
              Sergey

              OK, have you tried doing it without the multicast keyword?

              • 4. Re: Multicast Routing on NX-OS within vrf
                gavsparks

                Yeah it fails without the keyword:

                ping 224.1.2.3 vrf VRF_RED source 192.168.0.254

                ping: either multicast replicate flag or source interface needs to be specified

                 

                Only works if you type ping and go through the menu.

                Very odd

                • 5. Re: Multicast Routing on NX-OS within vrf
                  Sergey

                  gavsparks,

                   

                  OK, can you try to join the Ethernet subinterface to the multicast group, rather than the loopback and see if that works.

                  • 6. Re: Multicast Routing on NX-OS within vrf
                    gavsparks

                    I had a feeling you might ask that. Yea I'm afraid that does not work either.

                    Neither does using the command:

                    int x/y

                    ip igmp static-oif 224.1.2.3

                     

                    The mroute table looks good so this must be a "feature" or something

                     

                    Someone else has run into this:

                     

                    Multicast Commands - Cisco Support Community

                    • 7. Re: Multicast Routing on NX-OS within vrf
                      Sergey

                      One thing to check when you do join a physical interface is if spine switch gets an IGMP record for it

                      • 8. Re: Multicast Routing on NX-OS within vrf
                        Micheline

                        Hello Gavsparks--for IP multicast using PIM, you need to make sure that the unicast underlay works first.  (Sergey assumed this, but I don't think you should.). Leaf1 and Leaf2 should be OSPF neighbors with Spine1 and should have exchanged all of their loopback routes.  You also need to make sure each leaf has a unicast route to the RP address.  Finally, I believe that you need to make sure that the Loopback 0 interface on Spine 1 representing the RP needs to join the group with ip igmp join-gr 224.1.2.3.

                         

                        MM

                        • 9. Re: Multicast Routing on NX-OS within vrf
                          gavsparks

                          HI thanks for the information.

                          The underlay is working fine ospf is converged and i can ping all the addresses. Multicast is working i have confirmed by using a multicast application over the leaf spine.

                          The issue seems to be with using the command:

                          ping multicast

                           

                          Extended ping works fine so i assume this is a bug.


                          Thanks

                          • 10. Re: Multicast Routing on NX-OS within vrf
                            Micheline

                            Cisco Nexus 9000 Series NX-OS Release Notes, Release 7.0(3)I4(1) - Cisco didn't find any listed bugs in the release notes for ping multi. I also have 9300s and my code is only a little newer--I'm running 7.1--but I get ping multi returns just fine.  Hmmm...

                             

                            MM

                            • 11. Re: Multicast Routing on NX-OS within vrf
                              gavsparks

                              Hi, I've figured it out now. It was user error or at least my understanding of the command is at fault.

                               

                              I was issuing:

                              ping multi 224.6.6.6 interface loopback0 vrf VRF_RED source 192.168.0.254   (this fails).

                               

                              However if I use one of the Spine physical interfaces it works fine.

                              ping multi 224.6.6.6 interface ethernet 1/3.1 vrf VRF_RED source 192.168.0.254

                               

                              PING 224.6.6.6 (224.6.6.6) from 192.168.0.254: 56 data bytes

                              64 bytes from 192.168.2.1: icmp_seq=0 ttl=254 time=0.883 ms

                              64 bytes from 192.168.2.1: icmp_seq=1 ttl=254 time=1.052 ms

                              64 bytes from 192.168.2.1: icmp_seq=2 ttl=254 time=0.794 ms

                              64 bytes from 192.168.2.1: icmp_seq=3 ttl=254 time=0.951 ms

                              64 bytes from 192.168.2.1: icmp_seq=4 ttl=254 time=0.705 ms

                               

                              ping multi 224.6.6.6 interface ethernet 1/6.1 vrf VRF_RED source 192.168.0.254

                               

                              PING 224.6.6.6 (224.6.6.6): 56 data bytes

                              64 bytes from 192.168.2.7: icmp_seq=0 ttl=254 time=0.982 ms

                              64 bytes from 192.168.2.7: icmp_seq=1 ttl=254 time=0.615 ms

                              64 bytes from 192.168.2.7: icmp_seq=2 ttl=254 time=0.586 ms

                              64 bytes from 192.168.2.7: icmp_seq=3 ttl=254 time=0.575 ms

                              64 bytes from 192.168.2.7: icmp_seq=4 ttl=254 time=0.583 ms

                              • 12. Re: Multicast Routing on NX-OS within vrf
                                Micheline

                                Great to hear that you figured it out!   Great job!  MM

                                • 13. Re: Multicast Routing on NX-OS within vrf
                                  Naresh Myaka

                                  Hi Gavsparks,

                                   

                                  Can you please tell me what is 192.168.0.254 and what is need to specify interface.

                                   

                                  Am new to nxos and trying to understand how ping multicast command works differently.

                                   

                                  Thanks