1 2 Previous Next 16 Replies Latest reply: Apr 20, 2017 3:26 PM by Dalibor RSS

    VIRL - GETTING ERROR 503 - Service Unavailable

    Diego Capello

      Hi VIRL Community;

      I'm running VIRL on packet using virl_boxcutter. After a couple of successful deployments I began to get the following error:



      ERROR 503.png


      After I executed the "terraform apply ." command I received tons of failed


      I made some investigation regarding the issue and it looks like the server is not listening on the ports that should listen:


      virl@f7DDtLr0:~$ sudo netstat -lan | grep 1940*

      tcp        0      0 *               LISTEN

      tcp        0      0 *               LISTEN

      tcp        0      0          ESTABLISHED

      tcp        0      0         ESTABLISHED

      unix  2      [ ACC ]     STREAM     LISTENING     10194    /run/lvm/lvmpolld.socket



      [Sat Apr 15 09:39:02.835704 2017] [proxy:error] [pid 4791:tid 139651247462144] (111)Connection refused: AH00957: HTTP: attempt to connect to [::1]:19400 (localhost) failed

      [Sat Apr 15 09:39:02.835771 2017] [proxy:error] [pid 4791:tid 139651247462144] AH00959: ap_proxy_connect_backend disabling worker for (localhost) for 60s

      [Sat Apr 15 09:39:02.835803 2017] [proxy_http:error] [pid 4791:tid 139651247462144] [client] AH01114: HTTP: failed to make connection to backend: localhost



      I think the problem started when I upgraded the Ubuntu system using UWD but I cannot remember what I exactly upgraded.


      After that I started everything again according to the tutorial:

      - vagrant destroy.

      - Remove the boxcutter directory and clone again from the repo.

      - Edit the minion.pem, settings.tf and id.conf files.

      - vagrant up

      - terraform plan, terraform apply, etc

      but still getting the same results.


      Can anyone please help me with the issue?


      Thank you.




      Diego Capello

        1 2 Previous Next