6 Replies Latest reply: Apr 22, 2017 4:30 PM by Treschen1 RSS

    Active and unreachable

    david

      Tried all the steps, nodes still show as active and unreachable. Cannot SSH to the nodes, gave it a bunch of time, used to work. stopped working after an upgrade a month ago, I have just got tired of messing with it. Now, I need it. Tried re-installing VIRL from scratch, nothing seems to be working.

       

      Running on VM workstation Pro.

      The error I get under system tools is that the launch did not finish in the time limit.

      and

      Executing test

      Creating VIRL clients

      Stopping simulation "session-Mp4BAm"

      Failed to stop simulation "session-Mp4BAm": "STD simengine-status request [GET] http://localhost:19399/simengine/rest/status/session-Mp4BAm received invalid response status 401 (Failed to authenticate - incorrect password for user "system-test".)"

      Deleting project "system-test"

      Failed to delete project "system-test": "UWM project-delete request [DELETE] http://localhost:19400/rest/projects/system-test received invalid response status 403 (Project user "system-test" has active simulations)"

       

       

      Did all this:

      1. Run the following commands (in order):
        1. vinstall vinstall
        2. vinstall salt
        3. sudo salt-call state.sls virl.host  <<< this will build the /etc/network/interfaces
        4. sudo reboot
      2. After reboot, reset Openstack
        1. sudo salt-call state.sls openstack
        2. sudo salt-call state.sls openstack.reset
        3. sudo salt-call state.sls openstack.restart
      3. Check Openstack services
        1. nova service-list
        2. neutron net-list
        3. neutron agent-list