7 Replies Latest reply: Feb 25, 2017 11:20 PM by Kamlesh RSS

    vrf-lite question

    PKGranville

      Hi all,

      I have the following topology:

      topology.jpg

       

      I can't seem to form neighbourship between the 'common' router and 'voice' router.

      Here is my configurations:

       

      common router

      ip vrf VOICE

      !

       

      interface GigabitEthernet0/1.2

      encapsulation dot1Q 2

      ip vrf forwarding VOICE

      ip address 192.0.2.1 255.255.255.0

      !

      router ospf 1 vrf VOICE

      network 0.0.0.0 255.255.255.255 area 0

       

       

      voice router

      interface GigabitEthernet0/1

      ip address 192.0.2.2 255.255.255.252

      duplex auto

      speed auto

      media-type rj45

      !

      interface GigabitEthernet0/2

      ip address 10.1.1.1 255.255.255.0

      duplex auto

      speed auto

      media-type rj45

      !

      router ospf 1

      network 0.0.0.0 255.255.255.255 area 0

       

      Did a debug and both routers receive hello packets.

      Any help would be appreciated.

       

      thanks

        • 1. Re: vrf-lite question
          raymond

          Hi PKGranville

           

          Could you please post the output of a debug ip ospf adj

           

          Cheers

          • 2. Re: vrf-lite question
            raymond

            never mind, your subnet mask is wrong

             

            ip address 192.0.2.2 255.255.255.252

             

            and

             

            ip address 192.0.2.1 255.255.255.0


            These need to match for OSPF to form an adjacency


            Cheers

            • 3. Re: vrf-lite question
              Steven Williams

              Yes, Look up the requirements that each neighbor needs to meet to form an adjacency.

              • 4. Re: vrf-lite question
                vishnu

                Check the Subnet mask .

                • 5. Re: vrf-lite question
                  Brandon

                  I tried this in GNS3 and noticed a couple of things.

                  1. The common router seemed to want to require a router-id for ospf. (don't think this is the issue though)
                  2. check the vlans.  Typically the port between the common router and the switch would be a trunk and the port from the switch to the voice should be on vlan 2.  At least that's my thoughts. 

                   

                   

                  I don't believe it to be the subnet mask so much because a /30 would fit .1 and .2 within it.

                   

                  I'm going to lab this on my routers to see what I get.

                  • 6. Re: vrf-lite question
                    Brandon

                    It is the subnet mask as others have stated above.  Here's my debug:

                     

                    R2voice#debug ip ospf hello

                    OSPF hello debugging is on

                    R2voice#

                    Jan  2 13:05:50.311: OSPF-1 HELLO Fa0/0: Send hello to 224.0.0.5 area 0 from 192.0.2.2

                    Jan  2 13:05:53.271: OSPF-1 HELLO Fa0/0: Rcv hello from 255.255.255.240 area 0 192.0.2.1

                    Jan  2 13:05:53.271: OSPF-1 HELLO Fa0/0: Mismatched hello parameters from 192.0.2.1

                    Jan  2 13:05:53.271: OSPF-1 HELLO Fa0/0: Dead R 40 C 40, Hello R 10 C 10 Mask R 255.255.255.0 C 255.255.255.252

                     

                    I'm thinking that the R=Received and the C=connected(or configured locally) so the received mask is different than the connected/configured and so is causing a mismatched hello error.  It is not going to form an adjacency.

                     

                     

                     

                     

                    If you have the official cert guide on page 274 under ospf fundamentals

                    subnet mask must match.

                    • 7. Re: vrf-lite question
                      Kamlesh

                      mismatch in subnet mask is the problem, HELLO packet that is used to form adjacency contains the below and they have to match

                       

                      1. Router ID of the origination router
                      2. Area ID  of the originating router
                      3. IP address and subnet mask of the origination interface
                      4. Authentication type and its information of originating interface
                      5. HELLO interval of originating interface
                      6. Router Dead Interval of originating interface
                      7. Router Priority
                      8. DR and BDR
                      9. 5 flag bits about capability
                      10. Router IDs of originating router's neighbors