10 Replies Latest reply: Jul 10, 2014 10:53 PM by PatrickSun RSS

    OSPF Areas

    Alex

      Hi All,

       

      A cut out of the ospf config -

       

      router ospf 100

      log-adjacency-changes

      network 192.168.40.0 0.0.0.255 area 100

      network 192.168.50.0 0.0.0.255 area 100

      network 192.168.100.0 0.0.0.255 area 100

      network 192.168.200.0 0.0.0.255 area 100

       

      Just wondering if such things can be done,

       

      I would like to have multiple areas under one ospf AS

       

      Eg,

       

      router ospf 100

      log-adjacency-changes

      network 192.168.40.0 0.0.0.255 area 300

      network 192.168.50.0 0.0.0.255 area 300

      network 192.168.100.0 0.0.0.255 area 100

      network 192.168.200.0 0.0.0.255 area 100

       

      OR do i have to create another AS number for the 192.168.40.0 & 192.168.50.0

       

      E,g

       

      router ospf 100

      log-adjacency-changes

      network 192.168.100.0 0.0.0.255 area 100

      network 192.168.200.0 0.0.0.255 area 100

       

      router ospf 300

      log-adjacency-changes

      network 192.168.40.0 0.0.0.255 area 300

      network 192.168.50.0 0.0.0.255 area 300

       

      regards,
      Alex

        • 1. Re: OSPF Areas
          jgmarr

          Hi,

          Yes, both configuration are possible.

           

          Have in mind that LSAs inside one ospf process (local significant) do not pass to the other ospf process residing in the same router, unless you perform redistribution.

           

          Let's suppose your above config which reference 2 ospf process, adding a link inside area 0 to ospf process 100, so it is an area border router, backbone router.

          Link states inside ospf process 100 are not going to exist in the process 300, even in the same area.

           

          Regards.

          • 2. Re: OSPF Areas
            Alex

            @jgmarr - Thanks but I'm still lost ...

            • 3. Re: OSPF Areas
              sg4rb0sss

              You can have loads of areas under one OSPF process. The AS = Autonomous System, so you would usually just have the one AS per company.

               

              The rule is that any area MUST connect to the backbone area (area 0). The only exception is if you are using tunnels or virtual links.

               

              Steve

              • 4. Re: OSPF Areas
                Ahmad

                Hi Alex,

                 

                 

                It is possible to do so and it dose not REALLY matter how you do it:

                 

                 

                Router OSPF AS command creates and OSPF process with the AS number(this number is LOCALLY significant) and its not really a different process like EIGRP, so as far as neighbor relationships and LSAs OSPF ignores the AS you define, you can have a look athere

                 

                So as for your question it really dose not matter how you do it(defiantly its a better practice and recommended to use the same AS number for deferent areas and design)

                as for areas they just logically group your routers and manage how/where the OSPF calculation algorithm(Djakarta) works. You can have look atthis for more information about areas.

                 

                Cheers,

                 

                Ahmad

                • 5. Re: OSPF Areas
                  jgmarr

                  Hi Alex,

                   

                  One example could be good at this moment.

                   

                  You can figure out the following in GNS3:

                  R1 - R2 - R3

                   

                  R2 with 2 areas plus backbone area.

                  router ospf 100

                  network 192.168.100.0 0.0.0.255 area 100

                  network 100.100.100.1 0.0.0.0 area 0

                   

                  router ospf 200

                  network 192.168.200.0 0.0.0.255 area 200

                   

                  R1

                  router ospf 1

                  network 192.168.100.0 0.0.0.255 area 100

                   

                  R3

                  network 192.168.200.0 0.0.0.255 area 200

                   

                  After neighborship and adjacencies are establish check lsa in r3 and r1. You will not see lsa created by r1 in r3, neither viceversa.

                   

                  What I suggest you, have in mind the behavior, and make your design regarding your requirements.

                   

                  Regards.

                  • 6. Re: OSPF Areas
                    Alex

                    Thanks for all the replies. I have got the hang of things. Basically if I need to go through Area 0, I would need to use virtual link and the area at which then transit link passes through.

                    Posted from my mobile device.

                    • 7. Re: OSPF Areas
                      Prashant

                      Hi in order to configure OSPF following are the ways

                      router ospf process-id

                      network network-id wcm area area-id

                      where wild card mask is the inverse of subnet mask

                      wild card mask can be written as follows

                      255.255.255.255

                      255.255.255.0

                      0.0.0.255

                      In interface in order to configure ospf

                      for eg

                      interface fa0/0

                      ip ospf process-id area area-id

                      interface s0/0

                      ip ospf process-d area area-id

                      • 8. Re: OSPF Areas
                        Richard Burts

                        Alex

                         

                        From a syntax perspective your original suggestion of

                        network 192.168.40.0 0.0.0.255 area 300

                        network 192.168.50.0 0.0.0.255 area 300

                        network 192.168.100.0 0.0.0.255 area 100

                        network 192.168.200.0 0.0.0.255 area 100

                        would work and would create two areas and process OSPF in each area.

                         

                        But there is a tricky thing about this, which has been sort of suggested in previous posts. The tricky thing is that when there are multiple areas (such as your example) but not an area 0 (as in your example) the OSPF areas do not share routing information with each other. So in your example the devices within area 100 will communicate with each other but not with devices in area 300. And devices within area 300 will communicate with each other but not with devices in area 100.

                         

                        So the important thing to remember is that when you are configuring more than 1 OSPF area on a router there should be an area 0 configured on that router.

                         

                        HTH

                         

                        Rick

                        • 9. Re: OSPF Areas
                          Prashant

                          In order to configure ospf with areas it can be configured as follows

                          router ospf process-id

                          network network-id wild card mask area area-id

                          where area 0 is called as backbone area.

                          • 10. Re: OSPF Areas
                            PatrickSun

                            Hello Alex,

                             

                            It seems to me that what you ae callind AS (Autonomous System) is just a process ID which in the case of OSPF, only has a local significance (local to the router).

                            What exactly are you trying to accomplish here Alex?