12 Replies Latest reply: May 3, 2012 11:56 PM by just plain old Kev RSS

    New set of eyes

    Cameron Hughes

      Hey guys

       

      I can't see what I've done wrong. The chap is working to the isp but the ppp pap is not working too the NewB....

       

       

       

      HQ#sh run

      Building configuration...

       

      Current configuration : 1414 bytes

      !

      version 12.3

      no service timestamps log datetime msec

      no service timestamps debug datetime msec

      no service password-encryption

      !

      hostname HQ

      !

      !

      !

      !

      !

      !

      !

      !

      username ISP password 0 ciscochap

      username NewB password 0 ciscopap

      !

      !

      !

      !

      !

      !

      !

      spanning-tree mode pvst

      !

      !

      !

      !

      interface FastEthernet0/0

      ip address 10.0.1.1 255.255.255.0

      duplex auto

      speed auto

      !

      interface FastEthernet0/1

      no ip address

      duplex auto

      speed auto

      shutdown

      !

      interface Serial0/0/0

      no ip address

      encapsulation frame-relay

      frame-relay lmi-type q933a

      !

      interface Serial0/0/0.41 point-to-point

      ip address 10.255.255.1 255.255.255.252

      frame-relay interface-dlci 41

      clock rate 2000000

      !

      interface Serial0/0/0.42 point-to-point

      ip address 10.255.255.5 255.255.255.252

      frame-relay interface-dlci 42

      clock rate 2000000

      !

      interface Serial0/0/0.43 point-to-point

      ip address 10.255.255.9 255.255.255.252

      frame-relay interface-dlci 43

      clock rate 2000000

      !

      interface Serial0/0/1

      ip address 10.255.255.253 255.255.255.252

      encapsulation ppp

      ppp authentication pap

      ppp pap sent-username NewB password 0 ciscopap

      clock rate 64000

      !

      interface Serial0/1/0

      ip address 209.165.201.1 255.255.255.252

      encapsulation ppp

      ppp authentication chap

      !

      interface Serial0/1/1

      no ip address

      clock rate 2000000

      shutdown

      !

      interface Vlan1

      no ip address

      shutdown

      !

      ip classless

      !

      !

      !

      no cdp run

      !

      !

      !

      !

      !

      line con 0

      line vty 0 4

      login

      !

      !

      !

      end

       

       

      NewB#sh run

      Building configuration...

       

      Current configuration : 1108 bytes

      !

      version 12.3

      no service timestamps log datetime msec

      no service timestamps debug datetime msec

      no service password-encryption

      !

      hostname NewB

      !

      !

      !

      enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1

      enable password cisco

      !

      !

      ip dhcp excluded-address 10.4.5.1 10.4.5.10

      !

      ip dhcp pool B4_LAN

      network 10.4.5.0 255.255.255.0

      default-router 10.4.5.1

      dns-server 10.0.1.4

      !

      !

      !

      username HQ password 0 ciscopap

      !

      !

      !

      !

      !

      !

      !

      spanning-tree mode pvst

      !

      !

      !

      !

      interface FastEthernet0/0

      ip address 10.4.5.1 255.255.255.0

      duplex auto

      speed auto

      !

      interface FastEthernet0/1

      no ip address

      duplex auto

      speed auto

      shutdown

      !

      interface Serial0/0/0

      description Link to B4

      ip address 10.255.255.254 255.255.255.252

      encapsulation ppp

      ppp authentication pap

      ppp pap sent-username HQ password 0 ciscopap

      !

      interface Serial0/0/1

      no ip address

      clock rate 2000000

      shutdown

      !

      interface Vlan1

      no ip address

      shutdown

      !

      ip classless

      ip route 0.0.0.0 0.0.0.0 10.255.255.253

      !

      !

      !

      no cdp run

      !

      !

      !

      !

      !

      line con 0

      password cisco

      login

      line vty 0 4

      password cisco

      login

      line vty 5 15

      password cisco

      login

      !

      !

      !

      end

       

       

       

       

      I hope you see it.

       

      Thanks,

       

      Cameron

        • 1. Re: New set of eyes
          Martin

          hmmmm.. something about reversing user/password combination with routers;

           

          Try flipping up username password with those 2 routers:

           

          username HQ password 0 ciscopap  for router that does not have ppp pap sent-username HQ  in configuration;

           

           

          sent-username  Set outbound PAP username

          • 2. Re: New set of eyes
            Cameron Hughes

            So your saying to change, take off both the username and password HQ and redo the password and username but with the pap one done first?

             

            Thanks,

             

            Cameron

            • 3. Re: New set of eyes
              Martin

              router 1

              username HQ password 0 ciscopap

              ppp pap sent-username NewB password 0 ciscopap

               

              router 2

              username NewB password 0 ciscopap

              ppp pap sent-username HQ password 0 ciscopap

               

              try that ....

              • 4. Re: New set of eyes
                Cameron Hughes

                I really hate that that worked. Why did it work? I thought you always used the other router hostname for the username.... and the same password of course.

                 

                Thanks,

                 

                Cameron

                • 5. Re: New set of eyes
                  Martin

                  ppp authentication is confusing a bit; I always use debug ppp authentication when trying to figure it out.

                   

                  I think it is all about sent-username xxx in the packet

                  • 6. Re: New set of eyes
                    Cameron Hughes

                    yeah and I agree with you about the send username xxx is what it really cares about. Not the username under the global config. But why do I have to make the username the same as my hostname under global config?

                     

                    So only for chap you do the opposite hostname for the username/ password sameone

                     

                    and for pap

                     

                    you do your hostname for username under global config and password sameone

                     

                    then under the interface you do

                    ppp pap sent-username (other hosname) password sameone

                     

                     

                    Thanks,

                     

                    cameron

                    • 7. Re: New set of eyes
                      Martin

                      But why do I have to make the username the same as my hostname under global config?

                       

                      you do not have to

                      • 8. Re: New set of eyes
                        just plain old Kev

                        Cameron, I recognize that config...are you in an academy class doing the grand daddy of all packet tracer labs 8.6.1?

                         

                        Kevin

                        • 9. Re: New set of eyes
                          Cameron Hughes

                          Ok well I just went back and changed the global config usernames to yy and BB with the same password and got a up/down. then I took the username and password all the way off nd still under show ip int brief I have up/down.....

                           

                          The only way I can get it to work is to make the global config username same as the hostname.... hmmm.....

                           

                          Cameron

                          • 10. Re: New set of eyes
                            Martin

                            R1 and R2 using your HQ and New B combination

                             

                            R1#

                            *Mar  1 00:14:22.075: Se0/1 PPP: Authorization required

                            *Mar  1 00:14:22.139: Se0/1 PAP: Using hostname from interface PAP

                            *Mar  1 00:14:22.143: Se0/1 PAP: Using password from interface PAP

                            *Mar  1 00:14:22.143: Se0/1 PAP: O AUTH-REQ id 1 len 18 from "NewB"

                            *Mar  1 00:14:22.147: Se0/1 PAP: I AUTH-REQ id 14 len 16 from "HQ"

                            *Mar  1 00:14:22.151: Se0/1 PAP: Authenticating peer HQ

                            *Mar  1 00:14:22.167: Se0/1 PPP: Sent PAP LOGIN Request

                            *Mar  1 00:14:22.179: Se0/1 PPP: Received LOGIN Response PASS

                            *Mar  1 00:14:22.191: Se0/1 PPP: Sent LCP AUTHOR Request

                            *Mar  1 00:14:22.195: Se0/1 PPP: Sent IPCP AUTHOR Request

                            *Mar  1 00:14:22.211: Se0/1 LCP: Received AAA AUTHOR Response PASS

                            *Mar  1 00:14:22.215: Se0/1 IPCP: Received AAA AUTHOR Response PASS

                            *Mar  1 00:14:22.219: Se0/1 PAP: O AUTH-ACK id 14 len 5

                            *Mar  1 00:14:22.223: Se0/1 PAP: I AUTH-ACK id 1 len 5

                            *Mar  1 00:14:22.231: Se0/1 PPP: Sent CDPCP AUTHOR Request

                            *Mar  1 00:14:22.247: Se0/1 CDPCP: Received AAA AUTHOR Response PASS

                            *Mar  1 00:14:22.259: Se0/1 PPP: Sent IPCP AUTHOR Request

                             

                            *Mar  1 00:14:22.507: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/1 from LOADING to FULL, Loading Done

                             

                            *Mar  1 00:14:23.223: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

                             

                            using Using hostname from interface PAP is taken from ppp pap sent-username xxx

                            • 11. Re: New set of eyes
                              Cameron Hughes

                              Yes waldo I am. It's the last one.... I like GNS3 better but packet tracer already has the topology and It can be graded. I like seeing the percentage move and you know if you did the config right..... But I hate not having all the cmds....

                               

                              I'm done with class now. Prob take INCD1 in a week then INCD2 soon after.

                               

                              Were you in netacad? Did you feel it prepared you for the CCNA well enough?

                               

                              Thanks,

                               

                              Cameron

                              • 12. Re: New set of eyes
                                just plain old Kev

                                I work as a lab assistant in an academy.

                                 

                                As I just posted a minute ago, the academy is GREAT preparation for the exams...however is doesnt replace getting a study book designed specifically  for the exam you are taking, whether ccent or composite.

                                 

                                You must get a study book, as they are designed to help you pass the exam with one to one mapping of the exam blueprint.  Odom, Lammle or Cioara.

                                 

                                At the very least, get "31 days until your CCENT" or "31 days until your CCNA".  You could easily read the whole book in 7 days, with about 60/90 minutes of reading a day.

                                 

                                 

                                Kevin