12 Replies Latest reply: Apr 13, 2012 11:50 PM by Ashiq RSS

    EIGRP Configuration Issue

    Ashiq

      I tried to configure EIGRP in the below network, But I am getting this error

      R3(config-router)#

      *Apr 12 20:35:56.935: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 192.168.2.1 not on common subnet for FastEthernet0/0

      This is the network

      Router.jpg

      This is the running config for R3

      Building configuration...

       

      Current configuration : 1751 bytes

      !

      version 12.4

      service timestamps debug datetime msec

      service timestamps log datetime msec

      no service password-encryption

      !

      hostname R3

      !

      boot-start-marker

      boot-end-marker

      !

      !

      no aaa new-model

      ip cef

      !

      !

      !

      !

      !

      multilink bundle-name authenticated

      !

      !        

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      !

      interface FastEthernet0/0

      ip address 192.168.3.2 255.255.255.0

      duplex auto

      speed auto

      !

      interface FastEthernet0/1

      ip address 192.168.7.2 255.255.255.0

      duplex auto

      speed auto

      !

      interface Ethernet1/0

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet1/1

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet1/2

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet1/3

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet1/4

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet1/5

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet1/6

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet1/7

      no ip address

      shutdown

      duplex half

      !        

      interface Ethernet2/0

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet2/1

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet2/2

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet2/3

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet2/4

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet2/5

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet2/6

      no ip address

      shutdown

      duplex half

      !

      interface Ethernet2/7

      no ip address

      shutdown

      duplex half

      !

      router eigrp 1

      network 192.168.3.0

      network 192.168.7.0

      auto-summary

      !

      no ip http server

      no ip http secure-server

      !

      !

      !

      logging alarm informational

      !

      !

      !

      !

      !

      !

      control-plane

      !

      !

      !

      !

      !

      !

      gatekeeper

      shutdown

      !

      !

      line con 0

      stopbits 1

      line aux 0

      stopbits 1

      line vty 0 4

      login

      !

      !

      end

      Pls help me fix this.

        • 1. Re: EIGRP Configuration Issue
          chemilio

          Hi Ashiq,

           

          There is problem between Center router and R3 segment.  f0/0 on center 192.168.2.1  while f0/0 on R3 192.168.3.2.  The ip addresses are on different subnets that's why eigrp is complaining.

           

          HTH

           

          Chemillio.

          • 2. Re: EIGRP Configuration Issue
            DelVonte

            You have fa0/0 on R3 configured for 192.168.3.0/24, and according to diagram, Center is configured with 192.168.2.1, I'm assuming that R3 was intended to be configured with a 192.168.2.0/24 address. That will fix the problem.

             

            Regards,

             

            DelVonte

            • 3. Re: EIGRP Configuration Issue
              DelVonte

              You will also need to change the network statement for EIGRP on R3 from 192.168.3.0 to 192.168.2.0

              • 4. Re: EIGRP Configuration Issue
                Ashiq

                Thanks DelVonte. It worked.

                • 5. Re: EIGRP Configuration Issue
                  Ali Gheidarpour

                  Hi Ashiq,

                   

                  The first thing you should know about EIGRP is that EIGRP uses multicast hello packets to communicate to other EIGRP neighbors and when it receives an EIGRP hello packet sourced from an IP address on a subnet that is not configured on its receiving interface as a primary address will generates “not on common subnet” error message. Also may generates this error based on following issues:

                   

                  Misconfiguration of the interfaces or switch ports or cabling problem.

                   

                  Mismatch of primary/secondary IP addresses on the neighbor interface.

                   

                  A switch/hub is leaking multicast packets to other ports.

                   

                  If using a LAN switch, the vlans may have joined routers together.

                   

                  Another router uses EIGRP advertising on the same subnet/vlan as this router and is misconfigured with an incorrect AS number.

                   

                  To troubleshoot this issue, check these items:

                   

                  -          Double check the interface configuration for misconfigured IP address on local and neighboring routers

                   

                  -          Verify the primary address of the interface is in the same subnet as the primary address of the neighbor

                   

                  Another way to disable this error message is using the following command under the EIGRP process that is not recommended by Cisco but you can use this command to disable the error message in both sides but both sides never make neighbor relationship if you use different subnets:

                   

                  no eigrp log-neighbor-warnings

                  please note that: you can use this command if you run IOS release 11.3, 12.0 or later.

                  • 6. Re: EIGRP Configuration Issue
                    DelVonte

                    You're welcome.

                    • 7. Re: EIGRP Configuration Issue
                      Ashiq

                      Today I am having trouble with redistributing EIGRP to RIP

                      Redistibution.jpg

                      R4 is using RIP and other routers are running EIGRP, R4 routes do not show up on any of the EIGRP router and Vise Versa. I have also used the "No Auto-Summary" command. I don`t undersand what could be the problem.

                       

                      I have attached the Running Config of all the routers

                      • 8. Re: EIGRP Configuration Issue
                        DelVonte

                        You can't redistribute routes you are unaware of. Either R4 needs to be configured to be a part of the EIGRP domain, and/or R3 and/or R2 needs to be configured to be a part of RIP.

                        • 9. Re: EIGRP Configuration Issue
                          DelVonte

                          Also, its better to open a new discussion with a new title, and mark it as a question, that way you get the appropriate responses.

                           

                          Adding a new question to this discussion, will probably not get many new responders.

                           

                          Regards,

                           

                          DelVonte

                          • 10. Re: EIGRP Configuration Issue
                            gloryitak

                            Open a new discussion for this. Just looking at the configuration you attached here, you have not configure RIP on R2 yet you redistributed it under EIGRP.

                             

                            Same thing with R4, you redistributed EGRIP when you never configure one. I think you are practicing redistribution. You want R4 to get EIGRP routes. so removed the redistribute command under RIP. Like DelVonte already mention, configure atleast R2 link to R4, as a rip Link, then redistribute command on R2 will make sense to the router.

                             

                            To avoid some network issues, you can make put each link into a separate subnet. For example

                             

                            R1 - R2 = 192.168.1.0/30

                            R1 - R3 = 192.168.2.0/30

                             

                            R2 - R4 = 192.168.3.0/30 and so on

                            • 11. Re: EIGRP Configuration Issue
                              gloryitak

                              Hi Ashiq,

                               

                              I have made some configuration changes and got your redistribution working!

                               

                              See Attached text file for all 4 routers config files - Study them. There are other ways to get it going too.

                               

                              Have a good weekend!!

                               

                              Good-luck on your studies.

                               

                              Glory

                              • 12. Re: EIGRP Configuration Issue
                                Ashiq

                                You have saved me once again... I did have to break my head once again... What I did was, I configured RIP in R2 and redistributed it

                                 

                                But till I was not able to ping 192.168.1.5 and 192.168.1.6 from R4 and Ping failed from R1 to 192.168.1.22

                                 

                                Then I configured RIP on R3 as well and redistributed it and now the entire network is working fine, I understand that If I have to make the network reachabe I have to configure all the neighbours of R4 to redistribute, Am I correct ?

                                 

                                And next time I will definitely open up a new discussion, Sorry about that.

                                 

                                Thanks to Glory too