1 2 Previous Next 17 Replies Latest reply: Dec 13, 2013 5:17 AM by JOAQUIN RSS

    how can i enable 802.1q in my NIC ?????

    Amit

      hi

      i am trying to perform router on stick practical with real switch and virtual router in GNS3. but when i am ping to router fom switch or PC, it  doesn't work. i doubted on NIC card. 802.1Q  may not be enabled on it.

       

      i am using Realtek PCIe GBE Family Controller card in win 7 (64 bit). i already check "priority & VLAN", & it is enable....

        • 1. Re: how can i enable 802.1q in my NIC ?????
          Martin

          and before impelemnting router on stick you were able to ping back and forth, right ?

          • 2. Re: how can i enable 802.1q in my NIC ?????
            Kumar Mantri

            Hi Amit,

             

                  you mentioned your were using gns3 router with real pc so when doing this, did you configure the cloud? and you added  the nic to the cloud by adding loopback created on your pc or added the real nic of the pc?

            • 3. Re: how can i enable 802.1q in my NIC ?????
              Amit

              yes .....without encapsulation dot 1q in router, i can ping from router to switch n switch to router.....

               

              pl send me configuration of router on stick, particular for this case only (real switch n virtual router)...

              • 4. Re: how can i enable 802.1q in my NIC ?????
                Kumar Mantri

                Hi Amit,

                 

                this is the example configuration of router in a router on a stick setup

                 

                interface FastEthernet0/0.2

                encapsulation dot1Q 2

                ip address 10.0.0.1 255.255.255.0

                !

                interface FastEthernet0/0.3

                encapsulation dot1Q 3

                ip address 10.0.1.1 255.255.255.0

                • 5. Re: how can i enable 802.1q in my NIC ?????
                  Martin

                  oh, I see;  You want to be sure that your NIC has enabled priority & VLAN.

                   

                  If you have Wireshark then you can capture traffic; Ethernet frames with VLAN id will be larger than those without;

                   

                  You can use advanced ping using source of the interface with Vlan; and run debug ip icmp;

                   

                  Remember that Native in dot1q means that there is no extra info added to frames;

                  default Native Vlan is Vlan 1

                   

                  Ethernet with Vlan info = 114 bytes

                  Ethernet without Vlan info = 74 bytes

                   

                  Test Run could be performed on MS Loopback and GNS3.  MS Loopback NIC does not support 802.1Q for sure; so if you ping from MS loopback to rotuer and capture frames; then compare those to frames captured when pining from router to MS loopback; I bet you those will be different in size;

                   

                  I wonder if there is another way to tell Vlan id from captured packets/frames with Wireshark.

                  • 6. Re: how can i enable 802.1q in my NIC ?????
                    Amit

                    this is what the scenario that i am using.....

                     

                    dot1q.PNG

                     

                    when i ping form PC to Switch (192.168.50.2 or 51.2), it works.

                    but when ping form switch to router or PC to router, it does not work.

                     

                    Just for information....

                    PC to Switch (f0/9) configured as trunk

                    VLAN1, VLAN 50 & 51 are UP.......

                     

                    i don't know where did i wrong??????? is it possible my NIC does not support 802.1q????

                    • 7. Re: how can i enable 802.1q in my NIC ?????
                      Martin

                      First of all, I think you have 2 routers on stick; 1st at Router and 2nd at switch; right?

                       

                      Router-on-stick === Switch is usually done with L2 switch;

                      Router === L3 switch example, router-on-stick is the L3 switch, not router (router is just gateway, WAN).

                       

                      at L3 you can use assign IPs to Interfaces or to Vlans (SVI);

                       

                      Now, when you ping from PC, you using MS loopback. To figure it out why Pings work or not from Windows CMD to switch, look at Windows routing table; (Route Print from cmd); Same thing for other pings, show ip route on cisco devices will show you routes and default gateways.

                       

                      You would need another 2 PCs connected to Switch to test your pings appropriately;

                      To test your dot.1Q and router-on-stick, make your L3 Sw just L2 device;

                       

                      interface FastEthernet0/1

                      switchport mode trunk

                       

                      interface FastEthernet0/2

                      switchport access vlan 50

                       

                      interface FastEthernet0/3

                      switchport access vlan 51

                       

                      you need PCs plug into fa0/2 and 0/3 with IPs in correct vlans;

                       

                      in my documents, I have at least 3 examples of inter-Vlan routing for PT; search for those;

                      • 8. Re: how can i enable 802.1q in my NIC ?????
                        Kumar Mantri

                        Hi Amit,

                             when you ping 50.2 or 51.2 it first goes to the gateway configured on your pc ,in your example it is 192.168.1.10 so your ping to other networks always goes to switch not the router, as you mentioned switch model as 3550 L3 switch ,did you enable ip routing on L3?

                        • 9. Re: how can i enable 802.1q in my NIC ?????
                          Amit

                          i already used my switch as L2......i didn't used IP routing at my switch.......just configure VLAN 50 & 51.....and applied those vlan to int f0/10 & 11.....ip add on switch is just to check ping from laptop to switch....

                           

                          i also connect my desktop in vlan 50 (int f0/10) and ping to router but it didn't work....

                           

                          i talked to HP also, they said ur NIC support 802.1q & it is enable as well..... 

                           

                          i don't understand where  i am wrong???????????? is there any mistake in confuguration?????????

                          • 10. Re: how can i enable 802.1q in my NIC ?????
                            Martin

                            Inter-Vlan routing with L3 switch can be done 2 ways: over Vlans (SVI) and interfaces (with no switchport)

                            No need for router here;

                             

                            Router-on-stick is based on router with sub-interfaces connected to L2 switch;

                            There are several configurations for this method (native vlan 1 or other vlan #)

                             

                            Use just your L3 switch with laptop and desktop; no router; set ip routing and point PCs gateways to IPs on Vlans;

                            make sure switch ports are in access vlan #;

                            copy your run config from switch

                             

                            see my test document; I make it more readable later;

                            • 11. Re: how can i enable 802.1q in my NIC ?????
                              Amit

                              i already perform intervlan routing on L3 devices by applying IP ROUTING and it works...my laptop can ping to my desktop & vice versa....i put both, in different VLAN....

                               

                              but  when i perform router on stick, i coun't get ping from router to switch or switch to router.....i used  c3350 as L2 device... i just want to find out what the reasion, why i cant ping from switch to router or vice versa.....

                               

                              1) is there any problem with configuration ?????????????

                              2) or, my NIC card does not support 802.1q???????

                              3) or somethig else??????

                               

                              i am usng HP laptop with win 7....my NIC card is "realtek PCIe GBE family Controller"

                              yesterday, i again check with HP and they said your NIC is compitible with 802.1q......

                               

                              if, anybody has perform router-on-stick by using real switch and gns3.....pl send me detail of it????????????????????????

                              • 12. Re: how can i enable 802.1q in my NIC ?????
                                Martin

                                if what you ping is showing in routing table (as destination network), you should be able to ping OK

                                 

                                Run debug ip packets and debug ip icmp on switch and router;

                                 

                                ping from switch to rotuer; what happens? what is your output?

                                what is the source address and destintaion IP of pings ?

                                what is outgoing interface ?

                                does switch or router have destination IP in routing table?

                                are there encap errors? does pings gets to rotuer ?

                                if ping reaches router, can router send those back to the source?

                                 

                                Find out if vlan tagging is really suported (don't trust HP) from here (select your chip id to see more info)

                                 

                                http://www.realtek.com/products/productsView.aspx?Langid=1&PNid=7&PFid=10&Level=3&Conn=2

                                • 13. Re: how can i enable 802.1q in my NIC ?????
                                  vegaskid

                                  Hi Amit,

                                   

                                  my understanding is that you are running GNS3 on your laptop, with a virtual router interface connected to a cloud which is mapped to a physical NIC, which then connects to the physical switch. On the switch, this port is configured as a port and the router port is configured as a router on a switch i.e. sub-interfaces?

                                   

                                  Is it also correct that when you make it an access port and put the IP address on the physical router port (Fa0/0), you can ping both ways without an issue?

                                   

                                  The good news is...I have the same problem. The bad news is that I am not sure what the root cause is other than it being the physical NIC. Try this as a workaround:

                                   

                                  Make the VLAN you are trying to PING on the native VLAN on both ends of the link e.g.

                                   

                                  SW

                                   

                                  int fa0/9

                                  switchport trunk native vlan 50

                                   

                                   

                                  R1

                                   

                                  interface fa0/0.1

                                  encapsulation dot1q 50 native

                                   

                                   

                                  This effectively removes the tags from traffic on VLAN 50 whilst maintaining the rest of the config so you can confirm what is happening. (By the way, my advice would be to use a subinterface to match the VLAN so its easier to troubleshoot i.e. VLAN 50 on fa0/0.50).

                                   

                                  Obviously, this only works on that one VLAN! I tried the priotity and VLAN setting and adding VLANs and all sorts with a persistent PING in the background with no joy.

                                   

                                  Lots of reading online suggests people have had this issue and upgraded drivers or OS and it's resolved, or the other way around.

                                   

                                  Hope this gives you some ideas of how to progress. Email me at sirdotvegaskidatgmaildotcom if anybody finds the proper fix.

                                  • 14. Re: how can i enable 802.1q in my NIC ?????
                                    ryanhoibm

                                    HI Amit,

                                     

                                    so you got it working already? I faced the same issue too. I am using broadcom 5708C NIC. It does not have dot1q tag feature even though i have upgraded to the latest formware.

                                     

                                    I will buy linksys NIC

                                    1 2 Previous Next