2 Replies Latest reply: Oct 12, 2011 2:09 AM by cadetalain RSS

    redistribution backup route verification

    sg4rb0sss

      Hey guys.

       

      In the network below I want to r2 to use a rip route to get to 10.10.10.0/24, and have a backup route redistributed from r3 via OSPF.

       

      redistributed backup route.jpg

       

      R1#sh run

      hostname R1

      !

      interface Loopback1

      ip address 10.10.10.10 255.255.255.0

      !

      interface Loopback5

      ip address 1.1.1.1 255.255.255.255

      !

      interface FastEthernet0/0

      ip address 172.16.0.6 255.255.255.252

      !

      interface FastEthernet0/1

      ip address 172.16.0.2 255.255.255.252

      !

      router rip

      network 10.0.0.0

      network 172.16.0.0

       

       

       

      R2#sh run

      hostname R2

      !

      interface Loopback0

      ip address 2.2.2.2 255.255.255.255

      !

      interface FastEthernet0/0

      ip address 172.16.0.5 255.255.255.252

      !

      interface FastEthernet0/1

      ip address 192.168.1.2 255.255.255.0

      !

      router ospf 1

      log-adjacency-changes

      network 2.2.2.2 0.0.0.0 area 0

      network 192.168.1.0 0.0.0.255 area 0

      distance 200

      !

      router rip

      network 172.16.0.0

       

      R2 #sh ip route

           2.0.0.0/32 is subnetted, 1 subnets

      C       2.2.2.2 is directly connected, Loopback0

           3.0.0.0/32 is subnetted, 1 subnets

      O       3.3.3.3 [200/2] via 192.168.1.1, 00:21:02, FastEthernet0/1

           172.16.0.0/30 is subnetted, 2 subnets

      C       172.16.0.4 is directly connected, FastEthernet0/0

      R       172.16.0.0 [120/1] via 172.16.0.6, 00:00:03, FastEthernet0/0

      R    10.0.0.0/8 [120/1] via 172.16.0.6, 00:00:03, FastEthernet0/0

      C    192.168.1.0/24 is directly connected, FastEthernet0/1

       

       

      R2#sh ip ospf database external 10.0.0.0

       

       

                  OSPF Router with ID (192.168.1.2) (Process ID 1)

       

       

                      Type-5 AS External Link States

       

       

        Routing Bit Set on this LSA

        LS age: 1410

        Options: (No TOS-capability, DC)

        LS Type: AS External Link

        Link State ID: 10.0.0.0 (External Network Number )

        Advertising Router: 192.168.1.1

        LS Seq Number: 80000001

        Checksum: 0x4CDE

        Length: 36

        Network Mask: /8

              Metric Type: 2 (Larger than any link state path)

              TOS: 0

              Metric: 20

              Forward Address: 0.0.0.0

              External Route Tag: 0

       

       

       

      R3#sh run

      hostname R3

      !

      interface Loopback0

      ip address 3.3.3.3 255.255.255.255

      !

      interface FastEthernet0/0

      ip address 192.168.1.1 255.255.255.0

      !

      interface FastEthernet0/1

      ip address 172.16.0.1 255.255.255.252

      !

      router ospf 1

      log-adjacency-changes

      redistribute connected subnets

      redistribute rip subnets

      network 3.3.3.3 0.0.0.0 area 0

      network 192.168.1.0 0.0.0.255 area 0

      !

      router rip

      network 172.16.0.0

       

       

       

      As you can see, the 10.10.10.0/24 route is definately getting to R2.  Origionally the route was being learned via OSPF when I checked in the routing table.   Obviously the AD was lower, so it was prefering the path to the 10.10.10.0/24 network via r3.  However, I increased the AD of OPSF routes on R2.  And now it's only putting the rip route in the routing table (which is correct).  But now I'm wondering if there is some wonderful command that can show me the reasons why a route wasn't put into the routing table?  I definately understand why it's not in the routing table.  I just wanted to see if I could view in a show command why certain routes aren't inserted into the routing table?


      Cheers,
      Stephen