1 2 Previous Next 17 Replies Latest reply: May 31, 2011 7:06 PM by King RSS

    Switch to switch trunking not working

    King

      I am trunking my 2  3550 poe switches but it is not working. I already defined my vlans (vlan 10 voice and vlan 20 data)

      I have IP phones connected on them , but only the ones in Switch A which is connected to CME router are working. Now I am trying to create a trunk so that IP phones in Switch B work. Please advise, thanks

       

      Switch A config

       

      interface fa0/23

      switchport trunk encapsulation dot1q

      switchport mode trunk

      no shut

      vtp domain=cisco

      vtp pass=cisco

      vtp mode=server

       

      Switch B config

       

      interface fa0/23

      switchport trunk encapsulation dot1q

      switchport mode trunk

      no shut

      vtp domain=cisco

      vtp pass=cisco

      vtp mode=client

        • 1. Re: Switch to switch trunking not working
          Jared

          have you verified that VTP is pushing vlan 10 and 20 to the other switch?

          • 2. Re: Switch to switch trunking not working
            King

            All i did , created vlan 10 and 20 in both switches and defined vtp in both switches.

            • 3. Re: Switch to switch trunking not working
              Martin

              you have crossover cable, right ?

              • 4. Re: Switch to switch trunking not working
                Gabriel

                Your config seems right, check what 'Martin' and 'King' have pointed out and report back

                • 5. Re: Switch to switch trunking not working
                  tnewshott

                  Are the physical ports up when you look at them?  Are they up/up, and the trunk is merely not forming?

                   

                  As Martin alluded to, 3550s do not do auto-MDIX, which means you'll need a crossover to connect between them.

                  • 6. Re: Switch to switch trunking not working
                    King

                    I am using a crossover cable. And I don't have any light on those ports

                    • 7. Re: Switch to switch trunking not working
                      Martin

                      used switches, try another port, maybe some of port(s) are bad !

                       

                      port shutdown due to port-security; what is command to look at port security ?

                      • 8. Re: Switch to switch trunking not working
                        King

                        The command is show port security interface fa0/23.

                        I have tried other ports already, same result. Should I have to add these commands:

                         

                        switchport nonegotiate

                        spanning-tree portfast trunk

                        switchport trunk allowed vlan 10, 20

                        • 9. Re: Switch to switch trunking not working
                          Mike Gannon

                          Hi king,

                          Are you getting any error messages about the ports being half duplex?

                          I remember this happening a while ago.

                           

                          Set up an IP address in each VLAN and see if you can ping back to the Router interface to confirm you are getting L3 messages through the trunk

                          • 10. Re: Switch to switch trunking not working
                            Gabriel

                            I suggest you configure your setup in Packet tracer and upload it on here so that we all can see what you're doing? Of course it might work in Packet tracer, but someone might be able to point you in the right direction.

                            • 11. Re: Switch to switch trunking not working
                              King

                              No error messgae found at all.

                              • 12. Re: Switch to switch trunking not working
                                Mike Gannon

                                Ok I think we need to see configs as we're just guessing.

                                running-config and sh vtp stat, sh int trunk and sh int for one or two access ports.

                                • 13. Re: Switch to switch trunking not working
                                  Brian

                                  The configuration you have "looks" ok.  So to test if the trunk is indeed up and working, configure a vlan on the switch that is VTP server.  Say Vlan 200, then log on to the vtp client switch and see if VLAN 200 is there.  If is the trunk is up and working.  If not, then double check the VTP password.  while they look the same in the output above, try typing them again making sure to not add aspace at the end.  I have done this and while the trunk is up VTP will not work.

                                   

                                  In addition, I would like to see the complete configuration of both switches.

                                   

                                  HTH

                                   

                                  • 14. Re: Switch to switch trunking not working
                                    King

                                    SwitchA#sh run

                                    Building configuration...

                                     

                                    Current configuration : 1635 bytes

                                    !

                                    version 12.2

                                    no service password-encryption

                                    !

                                    hostname SwitchA

                                     

                                    interface FastEthernet0/1 (connected to PC1)

                                    switchport access vlan 200

                                    switchport mode access

                                    spanning-tree portfast

                                    !

                                    interface FastEthernet0/2

                                    switchport mode trunk

                                    spanning-tree portfast

                                     

                                    interface Vlan1

                                    no ip address

                                    shutdown

                                    !

                                    interface Vlan200

                                    ip address 192.168.1.1 255.255.255.0

                                     

                                    end

                                     

                                    SwitchA(config)#do sh vtp st

                                    VTP Version                     : 2

                                    Configuration Revision          : 0

                                    Maximum VLANs supported locally : 255

                                    Number of existing VLANs        : 6

                                    VTP Operating Mode              : Server

                                    VTP Domain Name                 : cisco

                                    VTP Pruning Mode                : Disabled

                                    VTP V2 Mode                     : Disabled

                                    VTP Traps Generation            : Disabled

                                    MD5 digest                      : 0x8D 0xEA 0x32 0xB8 0x8C 0xA3 0x98 0x51

                                    Configuration last modified by 0.0.0.0 at 3-1-93 00:05:10

                                    Local updater ID is 192.168.1.1 on interface Vl200 (lowest numbered VLAN interface found)

                                     

                                    SwitchB#sh run

                                    Building configuration...

                                     

                                    hostname SwitchB

                                     

                                    interface FastEthernet0/1 ( Connected to PC2)

                                    switchport access vlan 200

                                    switchport mode access

                                    spanning-tree portfast

                                    !

                                    interface FastEthernet0/2

                                    switchport mode trunk

                                    spanning-tree portfast

                                     

                                    interface Vlan1

                                    no ip address

                                    shutdown

                                    !

                                    interface Vlan200

                                    ip address 192.168.2.1 255.255.255.0

                                     

                                    end

                                     

                                    SwitchB#sh vtp st

                                    VTP Version                     : 2

                                    Configuration Revision          : 0

                                    Maximum VLANs supported locally : 255

                                    Number of existing VLANs        : 6

                                    VTP Operating Mode              : Client

                                    VTP Domain Name                 : cisco

                                    VTP Pruning Mode                : Disabled

                                    VTP V2 Mode                     : Disabled

                                    VTP Traps Generation            : Disabled

                                    MD5 digest                      : 0x65 0xE6 0x74 0xD6 0xCC 0xEF 0xC4 0x1D

                                    Configuration last modified by 0.0.0.0 at 3-1-93 00:13:04

                                    SwitchB#

                                     

                                    This is a packet Tracer simulation. And I configured it in the same way as my real switches. I would like know why the trunking between fa0/2 (switchA) and fa0/2 (switchB) is not working because PC1 (192.168.1.2) can't ping PC2 (192.168.2.2)

                                    I really dont' know what I am missing.

                                    Please advise, Thanks

                                    1 2 Previous Next