10 Replies Latest reply: Feb 15, 2009 1:15 PM by Armen RSS

    Can't, copy flash tftp

    Armen

       

      Hi all,

       

       

      I can't copy flash to tftp server. This is a router 2520 and I get this message:

       

       

      ERR: ' flash file name' open-file not found

       

       

      Which I already copy flash to this tftp server from different router, and worked.

       

       

      Thank you in advance

       

       

      Armen

       

       

        • 1. Re: Can't, copy flash tftp
          thelostpackets

           

          What tftp service are you using?

           

           

          • 2. Re: Can't, copy flash tftp
            Armen

             

            Hi Troy,

             

             

            I believe is TFTP32.

             

             

            • 3. Re: Can't, copy flash tftp
              B Haines

              Will you please give us a "show run" as well as a "show version"? Also please list a "show flash" since you are in it!

               

              sh run

              sh version

              sh flash

               

              Thanks!

              • 4. Re: Can't, copy flash tftp
                Armen

                 

                Current configuration:

                !

                version 11.3

                service timestamps debug uptime

                service timestamps log uptime

                no service password-encryption

                 

                hostname RouterB

                !

                enable secret 5 $1$qLpK$KsPGFe1gjHtEg36kDSSBU1

                enable password cisco

                 

                ip subnet-zero

                !

                 

                process-max-time 200

                !

                interface Ethernet0

                description LAN network for RouterB

                ip address 172.17.2.1 255.255.255.0

                 

                interface Serial0

                 

                 

                ip address 172.16.1.10 255.255.255.252

                no ip mroute-cache

                no fair-queue

                !

                interface Serial1

                description network connection to RouterA

                ip address 172.16.1.6 255.255.255.252

                 

                interface Serial2

                no ip address

                shutdown

                !

                interface Serial3

                no ip address

                shutdown

                 

                interface BRI0

                no ip address

                shutdown

                !

                router rip

                version 2

                network 172.16.0.0

                 

                 

                ip classless

                 

                !

                line con 0

                exec-timeout 0 0

                password cisco

                login

                line aux 0

                line vty 0 4

                exec-timeout 0 0

                password vty

                login

                 

                end

                 

                 

                opyright (c) 1986-1999 by cisco Systems, Inc.

                Compiled Fri 24-Sep-99 00:12 by pwade

                Image text-base: 0x0303B038, data-base: 0x00001000

                 

                 

                ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE

                BOOTFLASH: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE SOFTW

                ARE (fc1)

                 

                 

                RouterB uptime is 17 minutes

                System restarted by power-on

                System image file is "flash:c2500-is-l.113-11a.T1.bin", booted via flash

                 

                 

                cisco 2520 (68030) processor (revision M) with 14336K/2048K bytes of memory.

                Processor board ID 02805013, with hardware revision 00000002

                Bridging software.

                X.25 software, Version 3.0.0.

                Basic Rate ISDN software, Version 1.1.

                1 Ethernet/IEEE 802.3 interface(s)

                2 Serial network interface(s)

                2 Low-speed serial(sync/async) network interface(s)

                1 ISDN Basic Rate interface(s)

                32K bytes of non-volatile configuration memory.

                 

                 

                RouterB#sh flash

                 

                 

                System flash directory:

                File Length Name/status

                1 7245112 c2500-is-l.113-11a.T1.bin

                16384K bytes of processor board System flash (Read ONLY)

                 

                 

                • 5. Re: Can't, copy flash tftp
                  Armen

                   

                  RouterB#copy flash tftp

                   

                   

                  System flash directory:

                  File Length Name/status

                  1 7245112 c2500-is-l.113-11a.T1.bin

                  Address or name of remote host http://255.255.255.255? 172.17.1.2

                  Source file name? c2500-is-1.113-11a.T1.bin

                  Destination file name http://c2500-is-1.113-11a.T1.bin?

                  ERR: 'c2500-is-1.113-11a.T1.bin' open - file not found

                   

                   

                  RouterB#ping 172.17.1.2

                   

                   

                  Type escape sequence to abort.

                  Sending 5, 100-byte ICMP Echos to 172.17.1.2, timeout is 2 seconds:

                  !!!!!

                  Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms

                   

                   

                  • 6. Re: Can't, copy flash tftp
                    Kevin

                    It looks like you have a corrupt image file. If you have a good copy someplace else I would use it otherwise look at moving a good image file from the TFTP server back to the router.

                    • 7. Re: Can't, copy flash tftp
                      Conwyn

                      Hi Armen

                       

                      What is that http doing in the destination file name.

                       

                      Try copy flash:/c2500-is-1.113-11a.T1.bin tftp://172.17.1.2/c2500-is-1.113-11a.T1.bin

                       

                      Make sure you include the colons

                       

                      Regards Conwyn

                      • 8. Re: Can't, copy flash tftp
                        snarkout

                        That error means that IOS cannot find the file you're asking it to tftp.

                         

                        Your IOS image name: c2500-is-l.113-11a.T1.bin

                        What you're telling the IOS to tftp: c2500-is-1.113-11a.T1.bin

                         

                         

                         

                        The character after is- is incorrect - it should be a lower case L, not a one.

                        • 9. Re: Can't, copy flash tftp
                          Conwyn

                          Hi Snarkout

                           

                          Well spotted. I broke my first rule - never assume anything.

                           

                          Regards Conwyn

                          • 10. Re: Can't, copy flash tftp
                            Armen

                             

                            Well done, Snarkout ... You must have eagle's eyes. Thank you problem solved.

                             

                             

                            And thank you to every body else who participated to help me out.

                             

                             

                            Armen