Cisco Call Manager Express example configuration with Cisco 2811

     

    Nota:

    En esta configuracion encontraran un ejemplo de la configuracion de Call Manager Express, ademas este router tiene conectado otro router 2811 por medio de las interfaces FastEthernet 0/1 haciendo un tunnel de VPN es por eso la configuraicon de easyvpn.

     

     

    Saludos cordiales.

     

     

    Luis E. Ochaeta

     

     

    Building configuration...

     

    Current configuration : 5709 bytes

    !

    version 12.4

    service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption

     

    hostname CallManagerExpress

    !

    boot-start-marker

    boot-end-marker

     

    no logging buffered

    enable password class

    !

    no aaa new-model

     

    resource policy

    !

     

    !

    ip cef

     

    !

    no ip domain lookup

     

    !

     

    voice-card 0

    no dspfarm

    !

     

    crypto isakmp policy 1

    encr 3des

    authentication pre-share

    group 2

    !

    crypto isakmp policy 666

    hash md5

    authentication pre-share

    group 2

    crypto isakmp key cisco1234 address 172.30.2.2

     

    !

    crypto ipsec transform-set MINE esp-des

    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

    crypto ipsec transform-set ESP-3DES-SHA1 esp-3des esp-sha-hmac

    crypto ipsec transform-set ESP-3DES-SHA2 esp-3des esp-sha-hmac

     

    crypto map CASPMAP 666 ipsec-isakmp

    set peer 172.30.2.2

    set transform-set MINE

    match address 169

    !

    crypto map SDM_CMAP_1 1 ipsec-isakmp

    description Tunnel to172.30.2.2

    set peer 172.30.2.2

    set transform-set ESP-3DES-SHA2

    match address 103

     

    !

     

    !

     

    interface Tunnel0

    ip address 172.16.1.1 255.255.255.0

    ip mtu 1420

    tunnel source FastEthernet0/1

    tunnel destination 172.30.2.2

    tunnel path-mtu-discovery

    !

    interface FastEthernet0/0

    ip address 40.40.40.40 255.255.255.0

    duplex auto

    speed auto

     

    interface FastEthernet0/1

    ip address 172.30.1.2 255.255.255.0

    duplex auto

    speed auto

    no keepalive

    crypto map CASPMAP

    !

    router eigrp 1

    network 10.10.10.0 0.0.0.255

    network 10.0.0.0

    network 172.16.1.0 0.0.0.255

    network 172.16.2.0 0.0.0.255

    network 172.0.0.0 0.255.255.255

    no auto-summary

     

    ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 permanent

    ip route 30.30.30.0 255.255.255.0 40.40.40.1

    !

     

    ip http server

    no ip http secure-server

    !

    access-list 100 remark SDM_ACL Category=4

    access-list 100 permit gre host 172.30.1.2 host 172.30.2.2

    access-list 101 remark SDM_ACL Category=4

    access-list 101 permit gre host 172.30.1.2 host 172.30.2.2

    access-list 102 remark SDM_ACL Category=16

    access-list 102 permit ip host 40.40.40.40 host 172.30.1.2

    access-list 103 remark SDM_ACL Category=4

    access-list 103 permit gre host 172.30.1.2 host 172.30.2.2

    access-list 169 permit ip 100.0.1.0 0.0.0.255 100.0.2.0 0.0.0.255

     

    !

    control-plane

     

    !

    dial-peer voice 1 voip

    preference 1

    shutdown

    destination-pattern 20..

    session target ipv4:40.40.40.41

     

    dial-peer voice 2 voip

    destination-pattern 20..

    session target ipv4:40.40.40.70

    !

     

    !

     

    !

    telephony-service

    max-ephones 42

    max-dn 42

    ip source-address 40.40.40.40 port 2000

    auto assign 1 to 42

    max-conferences 8 gain -6

    transfer-system full-consult

    create cnf-files version-stamp Jan 01 2002 00:00:00

     

    !

    ephone-dn 1

    number 5550001

     

    !

    ephone-dn 2

    number 5550002

     

    !

    ephone-dn 3

    number 5550003

     

    !

    ephone-dn 4

    number 5550004

     

    !

    ephone-dn 5

    number 5550005

     

    !

    ephone-dn 6

    number 5550006

     

    !

    ephone-dn 7

    number 5550007

     

    !

    ephone-dn 8

    number 5550008

     

    !

    ephone-dn 9

    number 5550009

     

    !

    ephone-dn 10

    number 5550010

     

    !

    ephone-dn 11

    number 5550011

     

    !

    ephone-dn 12

    number 5550012

     

    !

    ephone-dn 13

    number 5550013

     

    !

    ephone-dn 14

    number 5550014

     

    !

    ephone-dn 15

    number 5550015

     

    !

    ephone-dn 16

    number 5550016

     

    !

    ephone-dn 17

    number 5550017

     

    !

    ephone-dn 18

    number 5550018

     

    !

    ephone-dn 19

    number 5550019

     

    !

    ephone-dn 20

    number 5550020

     

    !

    ephone-dn 21

    number 5550021

     

    !

    ephone-dn 22

    number 5550022

     

    !

    ephone-dn 23

    number 5550023

     

    !

    ephone-dn 24

    number 5550024

     

    !

    ephone-dn 25

    number 5550025

     

    !

    ephone-dn 26

    number 5550026

     

    !

    ephone-dn 27

    number 5550027

     

    !

    ephone-dn 28

    number 5550028

     

    !

    ephone-dn 29

    number 5550029

     

    !

    ephone-dn 30

    number 5550030

     

    !

    ephone-dn 31

    number 5550031

     

    !

    ephone-dn 32

    number 5550032

     

    !

    ephone-dn 33

    number 5550033

     

    !

    ephone-dn 34

    number 5550034

     

    !

    ephone-dn 35

    number 5550035

     

    !

    ephone-dn 36

    number 5550036

     

    !

    ephone-dn 37

    number 5550037

     

    !

    ephone-dn 38

    number 5550038

     

    !

    ephone-dn 39

    number 5550039

     

    !

    ephone-dn 40

    number 5550040

     

    !

    ephone-dn 41

    number 5550041

     

    !

    ephone-dn 42

    number 5550042

     

    !

    ephone 1

    no multicast-moh

     

    !

     

    ephone 2

    no multicast-moh

    !

     

    !

    ephone 3

    no multicast-moh

     

    !

     

    ephone 4

    no multicast-moh

    !

     

    !

    ephone 5

    no multicast-moh

     

    !

     

    ephone 6

    no multicast-moh

    !

     

    !

    ephone 7

    no multicast-moh

     

    !

     

    ephone 8

    no multicast-moh

    !

     

    !

    ephone 9

    no multicast-moh

     

    !

     

    ephone 10

    no multicast-moh

    !

     

    !

    ephone 11

    no multicast-moh

     

    !

     

    ephone 12

    no multicast-moh

    !

     

    !

    ephone 13

    no multicast-moh

     

    !

     

    ephone 14

    no multicast-moh

    !

     

    !

    ephone 15

    no multicast-moh

     

    !

     

    ephone 16

    no multicast-moh

    !

     

    !

    ephone 17

    no multicast-moh

     

    !

     

    ephone 18

    no multicast-moh

    !

     

    !

    ephone 19

    no multicast-moh

     

    !

     

    ephone 20

    no multicast-moh

    !

     

    !

    ephone 21

    no multicast-moh

     

    !

     

    ephone 22

    no multicast-moh

    !

     

    !

    ephone 23

    no multicast-moh

     

    !

     

    ephone 24

    no multicast-moh

    !

     

    !

    ephone 25

    no multicast-moh

     

    !

     

    ephone 26

    no multicast-moh

    !

     

    !

    ephone 27

    no multicast-moh

     

    !

     

    ephone 28

    no multicast-moh

    !

     

    !

    ephone 29

    no multicast-moh

     

    !

     

    ephone 30

    no multicast-moh

    !

     

    !

    ephone 31

    no multicast-moh

     

    !

     

    ephone 32

    no multicast-moh

    !

     

    !

    ephone 33

    no multicast-moh

     

    !

     

    ephone 34

    no multicast-moh

    !

     

    !

    ephone 35

    no multicast-moh

     

    !

     

    ephone 36

    no multicast-moh

    !

     

    !

    ephone 37

    no multicast-moh

     

    !

     

    ephone 38

    no multicast-moh

    !

     

    !

    ephone 39

    no multicast-moh

     

    !

     

    ephone 40

    no multicast-moh

    !

     

    !

    ephone 41

    no multicast-moh

     

    !

     

    ephone 42

    no multicast-moh

    !

     

    !

    line con 0

    exec-timeout 0 0

    line aux 0

    line vty 0 4

    password cisco

    login

    line vty 5 15

    password cisco

    login

     

    scheduler allocate 20000 1000

    !

    end